lp:ubuntu/vivid-proposed/ibus

Created by Ubuntu Package Importer on 2014-10-30 and last modified on 2015-04-04
Get this branch:
bzr branch lp:ubuntu/vivid-proposed/ibus
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

55. By Matthias Klose on 2015-04-04

Drop the ibus dependency on python-notify. According to the changelog,
pynotify support was removed a while ago (2008). Addresses #1440391.

54. By Iain Lane on 2015-01-26

Switch gnome-icon-theme to adwaita-icon-theme, which is its
successor. (LP: #1414613)

53. By Gianfranco Costamagna on 2014-10-28

* Merge from Debian unstable (LP: #1386776). Remaining changes:
  - Updated for making ibus-setup run under Unity.
  - Build with dh-translations
  - ubuntu-title-update.patch:
    Rename "IBus Preferences" to "Keyboard Input Methods"
  - ubuntu-no-notification.patch: Don't show the notification if not
    actually upgrading from a previous version.
  - ubuntu-disable-trigger.patch: Disable input method switching under
    Unity; it's handled by gnome-settings-daemon.
  - ubuntu-forward-panel-properties.patch:
    Augment the panel service D-Bus interface so that external consumers
    can detect when the panel service properties are changed.

52. By Ikuya Awashiro on 2014-10-09

* ubuntu-disable-trigger.patch:
  - Updated for making ibus-setup run under Unity (LP: #1379573).

51. By Aron Xu on 2014-08-18

* Merge from Debian (LP: #1352805), remaining changes:
  - Build with dh-translations
  - ubuntu-title-update.patch:
    Rename "IBus Preferences" to "Keyboard Input Methods"
  - ubuntu-no-notification.patch: Don't show the notification if not
    actually upgrading from a previous version.
  - ubuntu-disable-trigger.patch: Disable input method switching under
    Unity; it's handled by gnome-settings-daemon.
  - ubuntu-forward-panel-properties.patch:
    Augment the panel service D-Bus interface so that external consumers
    can detect when the panel service properties are changed.

50. By osamu on 2014-01-26

* New upstream release.
  - CVE-2013-4509 (also with FC19 patch). Closes: #729065
  - Update ibus-setup message. Closes: #729472
* Sync with ibus-1.5.5-1.fc19.src.rpm
* Update debian/rules using DEB_*_MAINT_APPEND (compat=9).
* Update README.Debian. Closes: #732434
* Update Standards-Version: 3.9.5

49. By osamu on 2013-10-15

* New upstream release.
* Depend on gir1.2-gtk-3.0 (>=3.8.5). Closes: #723031, #725134, #726467
* wrap-and-sort.
* Sync upstream with ibus-HEAD.patch which fixes candidate orientation
  bug. Closes: #725024

48. By osamu on 2013-09-14

Fix unowned files after purge: /etc/dconf/db/ibus
Closes: #722593

47. By osamu on 2013-09-11

* debian/control:
  - Depend on gir1.2-gtk-3.0 and python-gi. Closes: #722121
* debian/rules:
  - Simplify override_dh_install rule
  - Only hide ibus-setup in GNOME and Unity
  - Restore --disable-silent-rules

46. By osamu on 2013-09-06

* This initiates ibus 1.4 to 1.5 transition. This changes IM
  switching key to SUPER-space and integrates xkb.
  Closes: #690605, #699368
* Remove gjs and gnome-shell build dependency since ibus-gjs was
  removed.
* Add breaks to packages indirectly depending on python-ibus
  since ibus does not depend on python-ibus anymore.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/vivid/ibus
This branch contains Public information 
Everyone can see this information.

Subscribers