lp:ubuntu/vivid/flwm

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/vivid/flwm
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

13. By Axel Beckert

* Bump Standards-Version to 3.9.5 (no changes)
* Use dh_auto_clean instead of "make clean" + manual "rm -rf"
* Enable parallel building
* Spell "Windows" correctly and neutral also in the long package
  description of flwm-dbg.
* Drop obsolete man page removal in build target.
* Add a debian/upstream/metadata file according to DEP-12.

12. By Axel Beckert

* Bump debhelper compatibility to 9
  + Update versioned debhelper build-dependency
* Switch to a dh7 style debian/rules file:
  + Use dh_auto_{configure,build,install} and implicit dpkg-buildflags
  + Use dh_clean and debian/clean instead of manual "rm" where possible
  + Use debian/wm instead parameter to dh_installwm
  + Drop get-orig-source target
* Use dh_autoreconf
  + Add build-dependency on dh-autoreconf
* Pass CPPFLAGS inside CXXFLAGS to fix lintian warning
  hardening-no-fortify-functions.
  + Add build-dependency on dpkg-dev >= 1.16.1~
* Add flwm.desktop session file. Thanks Luca Capello! (Closes: #635044)
* Add patch by Stephen Carrier to fix FTBFS if ACTIVE_COLOR is defined
  (i.e. with modified config.h; Closes: #698021)
* Bump Standards-Version to 3.9.4 (no changes)
* Add lintian-overrides for no-upstream-changelog
* Apply wrap-and-sort

11. By Axel Beckert

* New Maintainer (Closes: #622165)
* Spell "Windows" correctly and neutral in the package description.
* Fix lintian warning debian-rules-missing-recommended-target.
* Add abort-on-upstream-changes and unapply-patches to
  debian/source/local-options as source format 3.0 stubbornly does not
  allow to put it into debian/source/options
* Add Vcs-* headers.

10. By Patrick Matthäi <email address hidden>

* Bump Standards-Version to 3.9.2 (no changes needed).
* Set the maintainer to the Debian QA Group.

9. By Patrick Matthäi <email address hidden>

* Bump Standards-Version to 3.9.1 (no changes needed).
* Convert package to the 3.0 (quilt) format.

8. By Patrick Matthäi <email address hidden>

* Fix typo in get-orig-source target.
* Refer in debian/copyright to the GPL-2 file instead of GPL.
* Add my own copyright for the Debian packaging.
* Update to compat 7.
* Use the new dh_installwm for registering flwm as one.

7. By Patrick Matthäi <email address hidden>

* Add missing ${misc:Depends}. Thanks lintian.
* Mangle cvs version tag in the Debian version.
* Add get-orig-source target.
* Bump Standards-Version to 3.8.1 (no changes needed).
* Change section of flwm-dbg to debug.
* Change my email address.
* Remove DM-Upload-Allowed control field.
* Fix lintian information using-first-person-in-description.

6. By Patrick Matthäi

Uploading to unstable.

5. By Patrick Matthäi

* Added 03-parantheses-warnings.dpatch. It adds some parantheses in the code
  and avoids so on some warnings from the compiler.
* Some minor header fixes for the 01 and 02 dpatch.

4. By Bill Allombert <email address hidden>

* New upstream release
 + Remove 100_double_ampersand applied upstream.
 + Otherwise this is identical to 1.01-1.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/wily/flwm
This branch contains Public information 
Everyone can see this information.

Subscribers