lp:ubuntu/vivid/apturl

Created by Ubuntu Package Importer on 2014-10-25 and last modified on 2015-05-10
Get this branch:
bzr branch lp:ubuntu/vivid/apturl
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

53. By Tim Lunn on 2015-04-02

[ Tim Lunn ]
* Don't use legacy icon names, these are no longer available in
  adwaita-icon-theme. (LP: #1437150)

[ Iain Lane ]
* For dialog-question, go back to using the stock icon name as Humanity
  doesn't yet have an icon with the new name.

52. By Iain Lane on 2015-01-26

Switch gnome-icon-theme to adwaita-icon-theme, which is its
successor. (LP: #1414613)

51. By Dimitri John Ledkov on 2014-03-16

Drop libgtk2-perl Recommends to Suggests.

50. By Sebastien Bacher on 2013-12-11

AptUrl/AptUrl.py: don't use decode on a str (lp: #1050826)

49. By Michael Vogt on 2013-10-08

adjust backend to reuse the bits from update-manager (LP: #1200775)

48. By Martin Pitt on 2013-04-09

* AptUrl/gtk/backend/__init__.py: Drop "action-done" signal definition;
  update-manager's GTK backend already defines it with different arguments,
  so this is ineffective and confusing.
* AptUrl/gtk/GtkUI.py, _on_backend_done(): Add additional error signal
  arguments, as defined by update-manager's backend.
* AptUrl/gtk/backend/InstallBackend{Aptdaemon,Synaptic}.py: Call action-done
  signal with error arguments. (LP: #1103024)
* data/apturl-gtk.ui: Drop obsolete "has_separator" property. Fixes a
  warning.

47. By Barry Warsaw on 2012-07-18

AptUrl/gtk/backend/InstallBackendAptdaemon.py: Work around
incompatible Update Manager API change (as described in Launchpad
bug #1026257). LP: #1020980

46. By Barry Warsaw on 2012-06-15

debian/control: Move python3-aptdaemon dependency to apturl binary
package (from apturl-common) since only the gtk backend needs it.

45. By Brian Murray on 2012-06-11

[ Brian Murray ]
* Port to Python 3:
  - Use Python 3 style print functions
* AptUrl/Parser.py:
  - ensure MAX_URL_LEN/10 returns an int

[ Colin Watson ]
* AptUrl/gtk/backend/InstallBackendSynaptic.py:
  - Keep a reference to the data tuple passed to GObject.child_watch_add
    to avoid attempts to destroy it without a thread context.
  - Open temporary synaptic selections file in text mode.

[ Barry Warsaw ]
* Additional Python 3 fixes:
  + Port setup.py to Python 3.
  + Use the new python-apt API since the legacy API is not available in
    Python 3.
  + ki18n() takes bytes.
  + Fix relative imports so the code can be run from source.
  + Fixed some additional packaging paths.
  + Change #! lines to use python3.
  + Changed debian/control and debian/rules to use python3.
  + Change debian/compat == 9
  + apturl now must require python3-aptdaemon.gtk3widgets (i.e. not |
    synaptic) due to the Python 3 port of update-manager.
* Other changes:
  + Remove the need for threads in the KDE front-end.
  + Enable running the test suite via `python3 -m unittest discover`
  + i18n updates.
  + Various and sundry pyflakes, whitespace, style, line length, and
    spelling fixes.

44. By Steve Langasek on 2012-03-24

Take the unicode representation of the parser error message instead
of the string representation, so that we get clean i18n handling.
LP: #911144.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/wily/apturl
This branch contains Public information 
Everyone can see this information.

Subscribers