lp:ubuntu/utopic/nettle

Created by Ubuntu Package Importer on 2014-04-25 and last modified on 2014-07-29
Get this branch:
bzr branch lp:ubuntu/utopic/nettle
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

17. By Magnus Holmgren on 2014-07-29

Use -fPIC instead of -fpic by default (Closes: #755769); needed on
sparc64 and shouldn't be noticeable elsewhere.

16. By Magnus Holmgren on 2014-04-18

* libhogweed2.symbols: Tag some internal functions implementing
  operations not available in GMP before version 6.0 as optional
  (Closes: #743087).
* Bump Standards-Version to 3.9.5.

15. By Magnus Holmgren on 2013-05-29

New upstream bugfix release.

14. By Magnus Holmgren on 2013-05-07

Tag some (ECC related) symbols that only exist on some architectures.

13. By Magnus Holmgren on 2012-11-16

* Add postinst script that replaces old documentation directory (from
  before 1.15-4) in nettle-bin with symlink (Closes: #692950).
* Spell check package descriptions (Closes: #680627). Thanks to Filipus
  Klutiero.

12. By Magnus Holmgren on 2012-06-23

* Drop README.source; not needed since the package was converted to
  format 3.0.
* Correct errors in DEP 5-format debian/copyright.
* Use dpkg-buildflags to set CFLAGS et al.
* Bump Standards-Version to 3.9.3.

11. By Magnus Holmgren on 2011-09-03

New upstream bugfix release.

10. By Magnus Holmgren on 2011-03-20

* Upload to unstable.
* Increase Debhelper compat level to 7.
* debian/rules: Add build-indep and build-arch targets.
* debian/copyright: Add entry for dsa2sexp.c.
* No longer suggest lsh-utils-doc as an alternative to lsh-doc.

9. By Matthias Klose on 2011-03-30

Configure with --disable-assembler for natty to fix a FTBFS. Should
be revisited with 2.1 in the o-series.

8. By Magnus Holmgren on 2009-10-11

* rsa2sexp_algorithm_name.dpatch (new): Use a default algorithm name
  that LSH understands in the sexp representation of an RSA key, so that
  pkcs1-conv can be used to convert existing OpenSSH private keys.
* debian/control: Add ${misc:Depends} to all packages lacking it.
* debian/control: nettle-dev: Depend on dpkg (>= 1.15.4) | install-info
  as recommended for the transition to triggerized install-info.
* Upgraded to Standards-Version 3.8.3 with the previous change.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/vivid/nettle
This branch contains Public information 
Everyone can see this information.

Subscribers