lp:ubuntu/utopic-proposed/gnome-do

Created by Ubuntu Package Importer on 2014-07-22 and last modified on 2015-04-17
Get this branch:
bzr branch lp:ubuntu/utopic-proposed/gnome-do
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

16. By Chris Halse Rogers on 2015-04-14

* debian/control: Update Homepage: to not point at spam URL. (LP: #1442873)
* debian/patches/06_fix_website_address.patch:
  - Update help links to not point at spam URL. (LP: #1363589)

15. By Chris Halse Rogers on 2014-12-07

* Don't initialise GDK threading; Do already executes all GTK code on the
  main thread, and the previous fix for glib's threading becoming more strict
  would deadlock while holding an X11 grab on startup if quiet mode was not
  enabled.
  - Fixes apparent system lockup (LP: #1396232)

14. By Chris Halse Rogers on 2014-08-20

Correctly call Gdk.Threads.Enter() before entering the GTK mainloop.
(LP: #1344386)

13. By Chris Halse Rogers on 2014-07-11

[ Iain Lane ]
* Build-depend directly on nunit instead of relying on indirect
* Build-depend on dbus-sharp instead of obsolete ndesk-dbus

[ Christopher James Halse Rogers ]
* Import new upstream 0.95 release (Closes: 713094, 708038)
* Transition to DBus# 2.0
* Simplify gnome-do launcher script (Closes: 650368)
* Version build-dependency on mono-cario; uses methods new in 3.2
* Add new GIO# and GKeyfile# build-depends
* Bump Standards-Version to 3.9.5, updating debian/copyright for
  machine-readable v1.0
* Import new upstream 0.95.1 release
* Drop versioned depends on Mono.Cairo; 0.95.1 builds against Mono < 3.2

12. By Chris Halse Rogers on 2012-03-26

* New upstream version no longer uses deprecated internal glib headers.
  (Closes: #665537)
* [59fa37b9] Fix watch file
* [63486516] Imported Upstream version 0.9
* [8c636d84] Disable testsuite for now; requires running dbus and gconf daemons
* [e46de4b9] Remove inaccurate README.Source
* [4591d677] Add git-buildpackage configuration to default to pristine-tar

11. By Chow Loong Jin on 2012-01-19

* Team upload
* Rebuild for CLR 4.0 transition
* [47deead] Move --with after $@ in dh call
* [721a2df] Move to debsrc 3.0 (quilt)
* [c849ac7] Refresh patches and drop dpatch cruft
* [0cdfb87] No-change Standards-Version bump (3.9.1 → 3.9.2)

10. By Iain Lane on 2011-12-06

* urgency=medium for RC bug fix (FTBFS)
* [c9c006a] Use dh_autoreconf --as-needed instead of manual patching

9. By Chris Halse Rogers on 2011-06-14

[ Christopher James Halse Rogers ]
* Imported Upstream version 0.8.5
  - Fix newline in Kazakh translation (Closes: #618415)
  - Fix build with mono >= 2.8.
* Remove unneeded .la files. (Closes: #621335)
* Drop patches included in new release
* Use ‘dh --with’ rather than cli.make to avoid warning spam
* Drop mention of Evolution from package description.
  - The evolution plugin is not going to be buildable for the forseeable
    future. Including it in the package description is misleading.

[ Iain Lane ]
* Add missing dependency on librsvg2-common, required to load SVGs
  (Closes: #619039)
* Update to use my d.o email address

8. By Chris Halse Rogers on 2011-02-15

* The long fortold release
  + Fixes a threadsafety issue resulting in 100% CPU usage (Closes: 565591,
    LP: #450852).
  + Proxies all keyring calls to the GTK main thread, as required by the new
    gnome-keyring (Closes: 603876, LP: #553643)
* debian/patches/00_bundledlibs.dpatch:
* debian/rules:
  + Upstream has dropped bundled gmcs binary; now 100% DFSG-free, so we don't
    have to repack the tarball or patch the buildsystem.
* debian/patches/03_disable_docky.dpatch:
  + Drop. Docky is now gone in the upstream tarball.
* debian/rules:
* debian/control:
* debian/patches/*:
  + Switch to quilt to harmonise with other pkg-cli-* packages.
* debian/control:
  + Drop recommends on gnome-do-docklets. Docky is now a separate package,
    so the docklets are useless for Do.
  + Bump Breaks on gnome-do-plugins to 0.8.3. Do no longer provides the Wink
    library, which has been imported into the 0.8.3 do-plugins sources.
  + Bump standards-version; no changes needed.
  + Migrate to git and update VCS fields appropriately

7. By Iain Lane on 2010-09-29

* debian/patches/03_disable_docky.dpatch: Add patch to disable Docky
  theme as this is now distributed as a separate project, in the docky
  package.
* debian/patches/04_dont_disable_deprecated.dpatch: Add patch to not
  build with *DISABLE_DEPRECATED. libdo uses deprecated symbols and
  FTBFS with these flags set. It's wrong to set them in release tarballs
  anyway.
* debian/control, debian/rules: Add dh-autoreconf to autoreconf in the
  build in order to pick up the above patches.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/utopic/gnome-do
This branch contains Public information 
Everyone can see this information.

Subscribers