lp:ubuntu/trusty-proposed/tuxguitar

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/trusty-proposed/tuxguitar
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

22. By gregor herrmann

* Team upload.
* Update list of alternative xulrunner-* dependencies.
* Remove debian/stamp-patched from source package.
* Declare compliance with Debian Policy 3.9.5.

21. By gregor herrmann

* Team upload.
* Update list of xulrunner-* versions in Depends to what we have in
  Debian.
  Thanks to Andreas Beckmann for the bug report. (Closes: #726730)
* Use canonical URLs for the Vcs-* fields.
* debian/rules: don't set DH_VERBOSE.
  Makes the build output more readable.

20. By Tony Mancill

* Update list of possible xulrunner dependencies (Closes: #712677)
* Add "file" to Depends; it is used in /usr/bin/tuxguitar.
* Allow java2-runtime (and thus openjdk-7-jre) to satisfy depends
  for tuxguitar-jsa. Remove sun JREs.

19. By Tony Mancill

[ Philippe Coval ]
* upgrade xulrunner (Closes: #661216)
* open to comaintenance in pkg-java team

[ tony mancill ]
* Convert d/copyright to machine readable format.
* Update Standards-Version to 3.9.3.

18. By Tony Mancill

* Add xulrunner-8.0 and 9.0 to list of dependencies (Closes: #647542)
* Modify debian/rules for BuildArchTarget release goal.

17. By Tony Mancill

Reorder build depends to address kfreebsd build problem.

16. By Tony Mancill

* debian/control:
  - Add xulrunner-7.0 as an alternate dependency. (Closes: #644921)
* debian/patches/01-tuxguitar-rzr.patch: Handle xulrunner-7.0.
* debian/patches/03-CVE-2010-3385.patch: Refresh/rediff.
  (Thanks to Daniel T Chen for the patch.)

15. By gregor herrmann

* Non-maintainer upload, with co-maintainer's permission.
* Fix "depends on obsolete xulrunner-1.9.1": update Depends and
  01-tuxguitar-rzr.patch (closes: #637372).

14. By Tony Mancill

* Update debian/control
  - build/depend on swt-gtk-3 (3.7) instead of 3.6.
  - replace build-dep on gcj with gcj-jdk
  - replace dependency on libswt-mozilla-gtk-3-jni
    with libswt-webkit-gtk-3-jni
* Update debian/patches/01-tuxguitar-rzr.patch for classpath changes

13. By Tony Mancill

* Update depend on swt-gtk 3.6 (Closes: #621864)
* Bump Standards-Version to 3.9.2.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/trusty/tuxguitar
This branch contains Public information 
Everyone can see this information.

Subscribers