lp:ubuntu/trusty/r-cran-genabel

Created by Ubuntu Package Importer on 2013-10-21 and last modified on 2013-10-21
Get this branch:
bzr branch lp:ubuntu/trusty/r-cran-genabel
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

8. By Andreas Tille on 2013-07-22

* New upstream version
* debian/control: Drop citation from long description because this
  information is provided in debian/upstream.

7. By Charles Plessy on 2013-05-01

* New upstream version
* Updated qvalue package name (moved from CRAN to Bioconductor).
* Drop references to old name r-other-genabel.
* Drop build-dependance on package only suggested.
* Normalised VCS URLs following Lintian's standard.
* Acquire R:Depends directly from r-base-dev.
* Normalised control file with cme.

6. By Andreas Tille on 2013-02-02

* New upstream version
* Replace debian/README.Debian by debian/README.test
* DEP5 copyright
* Standards-Version: 3.9.4 (no changes needed)
* debhelper 9 (control+compat)

5. By Andreas Tille on 2013-01-30

Fixing the problem which prevents the package from loading while
checking the version on CRAN
Closes: #699260

4. By Charles Plessy on 2012-01-13

* New upstream release.
* Depends and Suggests packages according to DESCRIPTION (debian/control).
* Corrected VCS URLs (debian/control).
* Conforms with Policy 3.9.2 (debian/control, no other changes needed).
* Build-Depend on r-cran-mass instead of the whole r-recommended.

3. By Charles Plessy on 2011-04-01

* New upstream release, buildable with R > 2.12 (closes: #620269).

[ Andreas Tille ]
* debian/control:
  - added myself to uploaders
  - changed section to gnu-r
  - Depend on ${R:Depends}
* debian/rules:
  - fix permissions of files that should not be executable
  - Require a number equal or superior than the R version the package
    was built with, using a R:Depends substvar

[ Charles Plessy ]
* debian/control:
  - Added myself to uploaders.
  - Use debhelper 8 (debian/compat).
  - Build-depend on R > 2.10 according to DESCRIPTION.
  - Replaces r-other-genabel.
  - Added Vcs-Browser and Vcs-Svn fields.
  - Updated homepage.
* Install CHANGES.LOG as upstream changelog (debian/rules).
* Converted debian/copyright to DEP-5 format.

2. By Steffen Möller on 2011-02-05

* New upstream release.
* The package has now arrived in CRAN and is taken from there,
  which according to the R policy is also reflected by the name change.
* Switch to source/format 3.0 (quilt)
* Bumped policy-standard to 3.9.1.

1. By Steffen Möller on 2011-02-05

Import upstream version 1.6-4

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/saucy/r-cran-genabel
This branch contains Public information 
Everyone can see this information.

Subscribers