lp:ubuntu/trusty/pyopencl

Created by Ubuntu Package Importer on 2013-10-18 and last modified on 2014-01-04
Get this branch:
bzr branch lp:ubuntu/trusty/pyopencl
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

15. By Matthias Klose on 2014-01-04

Rebuild for python3.4 as a supported python version.

14. By Tomasz Rybak <email address hidden> on 2013-11-28

* New upstream release.
* Remove unnecessary entry from debian/copyright.

13. By Dimitri John Ledkov on 2013-10-22

No change rebuild for Boost 1.54 transition.

12. By Tomasz Rybak <email address hidden> on 2013-06-17

* New upstream release.
* Add *-dbg packages.
* Remove *-headers package; upstream now ships headers in python directory.
* Upstream switched to setuptools, update patches to deal with it.
* Do not call dh_sphinxdoc for architecture dependent builds, build
  documentation in separate step in debian/rules (Closes: #711926)
* Add README.source describing get-orig-source in debian/rules.
* Disable package optimisation option as it might clash with hardening
  compile options.
* Include tests (all files in test/) in documentation package.
* Fix VCS-* fields to contain canonical URIs.
* Update Standards-Version to 3.9.4; no changes necessary.

11. By Dimitri John Ledkov on 2013-04-26

No change rebuild for Boost 1.53 transition.

10. By Dimitri John Ledkov on 2012-11-08

Installing fglrx breaks 3D acceleration on sandy-bridge (my work
machine). Therefore I am dropping "fglrx | nvidia-current" from
Depends fields. If you have opencl capable hardware and properly
setup, then you can enjoy this package.

9. By Matthias Klose on 2012-11-08

Rebuild to drop python3.2 extension.

8. By Dimitri John Ledkov on 2012-11-01

* Remove depends on opencl-icd, keep/add suggests
  "fglrx | nvidia-current" to make the python modules
  installable.
* Rebuild against python3.3.

7. By Dimitri John Ledkov on 2012-07-02

Skip sphinx documentation in binary-arch build. Fixes FTBFS.

6. By Tomasz Rybak <email address hidden> on 2012-06-21

* New upstream release.
* Depend on free ocl-icd-libopencl1 instead of non-free libraries.
* Add NEWS entry describing OpenCL library dependencies.
* Change my email.
* Move python-pyopengl from Recommends to Suggests because package
  can be used for computations without any graphical environment.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/saucy/pyopencl
This branch contains Public information 
Everyone can see this information.

Subscribers