lp:ubuntu/trusty/pandoc

Created by Ubuntu Package Importer on 2013-10-21 and last modified on 2014-02-06
Get this branch:
bzr branch lp:ubuntu/trusty/pandoc
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

34. By Colin Watson on 2014-02-06

Rebuild for new GHC ABIs.

33. By Colin Watson on 2014-01-01

Rebuild for new GHC ABIs.

32. By Jonas Smedegaard <email address hidden> on 2013-12-30

[ upstream ]
* New release.
  Closes: bug#724636, #731391.

[ Jonas Smedegaard ]
* Fix use relative symlink to S5 data files.
* Update upstream source URL and use TLS (https), in watch file,
  copyright file and CDBS hints in rules file.
  Mangle ~dfsg suffix in watch file.
* Update long description based on upstream cabal file (seems more
  accurate than upstream README), additionally mentioning PDF
  renderings of LaTeX and GNU Texinfo writer.
* Add NEWS file with entry on behavior changes, referring to upstream
  changelog for details.
* Update package relations:
  + Build-depend on alex and happy.
  + Suggest (not yet packaged) pandoc-citeproc.
  + Stop depending on libghc-citeproc-hs-data.
  + Add GHC (build-)dependencies on unordered-containers, aeson (and
    not json), attoparsec, yaml, hslua, http-conduit, http-types and
    text.
  + Tighten GHC (build-)dependencies on texmath, pandoc-types, tagsoup
    and highlighting-kate.
  + Drop GHC (build-)dependencies on citeproc-hs.
* Repackage upstream source to avoid minified LaTeXMathML.js code.
  Closes: bug#721417. Thanks to Luca Falavigna.
* Add patch 1001 to use online LaTeXMathML.js by default.
* Add patch 2001 to avoid dropped files during build.
* Update copyright file:
  + Stop covering slide show and LaTeXMathML Javascript code: No
    longer shipped.
  + Cover new Haddock reader: partly BSD-2-clause partly GPL-2+
    licensed.

31. By Jonas Smedegaard <email address hidden> on 2013-11-02

* Have pandoc depend on (not recommend) pandoc-data.
  Closes: bug#724102. Thanks to David Su├írez and others involved.
* Drop bogus note for backporters in changelog entry for 1.11.1-4.
  (note to self: never write notes here, always use README.Debian!).
* Have pandoc-data symlink and depend on separately packaged S5.
  Closes: bug#631848. Thanks to Clint Adams.
* Bump standards-version to 3.9.5.
* Update copyright file to document how Slidy is covered only by W3C
  software license (not also document license).
  Closes: bug#722134. Thanks to Francesco Poli.

30. By Jonas Smedegaard <email address hidden> on 2013-08-29

* Drop superfluous control file Section declaration.
* Fix reference to GHC 6 in long description.
* Introduce new binary-all package pandoc-data.
  Closes: bug#697306. Thanks to Joachim Breitner.
* Add symlink to unversioned datadir when versioned, to ease
  backporting. Reverse dependencies are recommended to use
    Depends: pandoc-data (<= 1.11.1-4~)
  for a smoothest ride.

29. By Colin Watson on 2013-06-17

Rebuild for new GHC ABIs.

28. By Colin Watson on 2013-05-30

Rebuild for new GHC ABIs.

27. By Joachim Breitner on 2013-05-25

Upload to unstable

26. By Colin Watson on 2013-05-01

Rebuild for new GHC ABIs.

25. By Jonas Smedegaard <email address hidden> on 2013-02-17

[ upstream ]
* New release.

[ Jonas Smedegaard ]
* Update copyright file:
  + Fix syntax for public-domain files.
  + Fix drop Files section for no longer shipped BSD-3-clause licensed
    files.
  + Extend coverage of main copyright holder.
* Drop patches: All applied upstream.
* Update long descriptions base on upstream README.
* Drop configure flag blaze_html_0_5: Now enabled dy default.
* Reorder *-doc build-dependencies to match *-dev ones.
* Update package relations:
  + (Build-)depend on GHC packages data-default and (not only *-doc)
    text: Needed since 1.10.
  + Stop (build-)depending on GHC packages utf8-string: Unneeded since
    1.10.
  + Tighten build-dependencies on GHC packages citeproc-hs,
    pandoc-types, diff, test-framework, test-framework-hunit,
    test-framework-quickcheck2 and template-haskell: Needed since
    1.10.
  + Stop build-depending on GHC -doc package xhtml: Unused since
    1.9.1.1.
  + Stop build-depending on GHC -doc package diff: Seemingly never
    actually used.
  + Build-depend on GHC -doc packages rts and utf8-string: Seemingly
    needed (even if undeclared).
  + Relax (build-dependencies on GHC packages ansi-terminal: Changed
    since 1.10.1.
* Shrink README.source to simply reference wiki page about used
  packaging style.
* Suppress dist/ dir in gpb.conf, as workaround for upstream shipping
  dirty build dir.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/saucy/pandoc
This branch contains Public information 
Everyone can see this information.

Subscribers