lp:ubuntu/trusty-proposed/libimobiledevice

Created by Ubuntu Package Importer on 2013-11-12 and last modified on 2014-03-18
Get this branch:
bzr branch lp:ubuntu/trusty-proposed/libimobiledevice
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

17. By Timo Jyrinki on 2014-03-14

[ Matthias Niess ]
* Replace a duplicate 'backup' util man page with the one for 'crashreport'

[ Timo Jyrinki ]
* New upstream snapshot. (LP: #1207812)
* Drop patches include in the upstream snapshot:
  - debian/patches/CVE-2013-2142.patch
  - debian/patches/git_explicitly_cast_ssl_enabled.patch
* Drop the python patch, new upstream method seems to work:
  - debian/patches/09_use_python_config.patch
* Refreshed remaining patches:
  - debian/patches/01-libs.private.patch
  - debian/patches/02-fix-link-errors.patch
* Drop libimobiledevice-doc, the git does not include html documentation
* Updated libimobiledevice4.symbols
* Add missing man page for the 'idevicename' util

16. By Matthias Klose on 2014-02-27

Rebuild for libtasn1-6 transition.

15. By Chow Loong Jin on 2013-10-30

[0052e46] Drop hal fdi file.
That stuff doesn't work anymore. (Closes: #728151)

14. By Chow Loong Jin on 2013-10-28

* Team upload.
* Ack NMU from Andreas Metzler
* [1282e33] Imported Upstream version 1.1.5 (Closes: #709369):
  - Adapt to libusbmuxd API changes (Closes: #682275)
* [27231df] Refresh or drop patches
  - 00git_ios5_support.patch: Drop, applied upstream
  - 01-libs.private.patch: Refresh
  - 02-add-missing-linking.patch: Drop, applied upstream
  - 03_ac_pkg_swig_m4_fixed.patch: Drop, no longer relevant
  - 04_libplist_DSO_linking.patch: Drop, applied upstream
  - 05_remove_gcry_need.patch: Drop, no longer relevant
* [0f497a0] Drop --host and --build arguments from configure.
  This is already applied by dh_auto_configure automatically.
* [a370ab0] Reindent build-depends and drop trailing whitespace
* [a3fffe5] Bump dh compat to 9 for buildflags
* [40725ee] Enable multi-arch
* [65d74c4] Move dh --with parameter after $@
* [596a2b7] Update command for removing *.la for multiarch path
* [979998b] Update .manpages file for new utilities
* [3c37d78] Don't ship embedded jquery.js

13. By Julien Lavergne on 2012-03-18

[ Robert Hooker ]
* Add 06_git_ios5_handle_error.patch, backport from git commit
  e855f246b3 to allow mounting ios 5 devices. (LP: #877440)

[ Julien Lavergne ]
* debian/control:
 - Remove build-depend on libusb2-dev. Thanks Robert Millan (Closes: #659625)
 - Update Standards-Version to 3.9.3 (no change needed).

12. By Julien Lavergne on 2011-10-25

* debian/patches:
 - 05_remove_gcry_need.patch: Remove check and link to gcrypt
   (Closes: #638417)
 - 00git_ios5_support.patch: Fix "Unhandled lockdown error" for iOS 5.
   (LP: #795475)

11. By Julien Lavergne on 2011-09-16

* Upload to unstable, most of the API should be stable now.
* debian/patches/
 - 02-add-missing-linking.patch: Refresh
 - 03_ac_pkg_swig_m4_fixed.patch: Fix building python bindings. Thanks
   Sebastian Ramacher for the patch (Closes: #631821).
 - 04_libplist_DSO_linking.patch: Add libplist to LDFLAGS.
* debian/control:
 - Build-depends on dh-autoreconf for 03_ac_pkg_swig_m4_fixed.patch.
 - Add DM-Upload-Allowed: yes
* debian/rules:
 - Run dh --with autoreconf for 03_ac_pkg_swig_m4_fixed.patch.
 - Remove .la files for python bindings also.
 - Remove .a files from python bindings.

10. By Julien Lavergne on 2011-05-03

* debian/control:
 - Remove Conflicts with libimobiledevice2 and libimobiledevice0 to make them
   installable with libimobiledevice1.
 - Remove Replaces with libimobiledevice2, handle by libimobiledevice2 itself.

9. By Julien Lavergne on 2011-04-17

* debian/control:
 - Add Conlicts / Replaces on libimobiledevice2 and libimobiledevice0, since
   they provide the same fdi file. (Closes: #620092)
 - Update Maintainer and add me to Uploaders.
 - Update Vcs-* fields.

8. By Julien Lavergne on 2011-03-26

* New upstream release.
* debian/31-apple-mobile-device.fdi
 - Re-add HAL fdi file, until Amarok don't rely on it.
   Closes: #615107
* debian/libimobiledevice1.install:
 - Install the HAL fdi file.
* debian/libimobiledevice-utils.manpages:
 - Add ideviceenterrecovery.1 to installed manpages.
 - Use idevicepair.1 from upstream.
* debian/idevicepair.1:
 - Remove to use the upstream one.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/trusty/libimobiledevice
This branch contains Public information 
Everyone can see this information.

Subscribers