lp:ubuntu/saucy-security/libav

Created by Ubuntu Package Importer on 2013-11-04 and last modified on 2014-07-15
Get this branch:
bzr branch lp:ubuntu/saucy-security/libav
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

38. By Marc Deslauriers on 2014-07-15

Update to 0.8.13 to fix multiple security issues (LP: #1341216)

37. By Marc Deslauriers on 2014-06-10

* SECURITY UPDATE: Update to 0.8.12 to fix multiple security issues
  - CVE-2014-3984

36. By Marc Deslauriers on 2014-02-06

Update to 0.8.10 to fix multiple security issues (LP: #1277173)

35. By Marc Deslauriers on 2013-11-09

Update to 0.8.9 to fix multiple security issues (LP: #1249621)

34. By Marc Deslauriers on 2013-10-21

Update to 0.8.8 to fix multiple security issues (LP: #1242802)

33. By William Grant on 2013-10-11

* debian/patches/{05-aarch64-support.patch,06-aarch64-pie.patch}:
  - Backport basic aarch64 support from git.

32. By Jackson Doak on 2013-07-11

* Merge from debian/unstable, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp, frei0r,
    vo-aacenc, vo-amrenc, x264, and xvid (all in universe)
  - do not build libav-extra-dbg, it is build from the libav-extra source
    package in ubuntu.
  - drop libav-regular-dbg, not necessary in ubuntu
  - Adjust LIB_PKGS/LIB_PKGS2 lists in debian/rules
  - several ifdefs in debian/rules that allow the use of the same file
    in libav and libav-extra (most of this can be merged into the debian
    package)

31. By Reinhard Tartler on 2013-03-30

Put back the dh_strip invocations. Otherwise, no .ddebs will be
available at all.

30. By Reinhard Tartler on 2013-03-27

* Merge from debian/unstable, LP: #1160734, remaining changes:
  - don't build against libdirac, lame, libopenjpeg, librtmp, frei0r,
    vo-aacenc, vo-amrenc, x264, and xvid (all in universe)
  - do not build libav-extra-dbg, it is build from the libav-extra source
    package in ubuntu.
  - drop libav-regular-dbg, not necessary in ubuntu
  - Adjust LIB_PKGS/LIB_PKGS2 lists in debian/rules
  - several ifdefs in debian/rules that allow the use of the same file
    in libav and libav-extra (most of this can be merged into the debian
    package)
* Tested that co-instability of libavcodec-dev with libavcodec-extra-53 works.
  LP: #1143929, #1101829
* Remove all debug packages. In ubuntu, we provide debug symbols via the
  .ddeb infrastructure.

29. By Marc Deslauriers on 2013-01-24

* Update to 0.8.5 to fix multiple security issues. (LP: #1104019)
  - CVE-2012-2783
  - CVE-2012-2791
  - CVE-2012-2797
  - CVE-2012-2798
  - CVE-2012-2801
  - CVE-2012-2802
  - CVE-2012-2803
  - CVE-2012-2804
  - CVE-2012-5144

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/trusty/libav
This branch contains Public information 
Everyone can see this information.

Subscribers