lp:ubuntu/saucy-proposed/gnome-desktop3

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/saucy-proposed/gnome-desktop3
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

30. By Alberto Milone

* debian/patches/ignore_errors_with_primary_outputs.patch:
  - Ignore failures when setting the primary output (LP: #1224254).

29. By Jeremy Bicha

* New upstream bugfix release
  - Initialize gettext before constructing a wall clock
  - Update pnp.ids from upstream hwdata
  - Fix crash when XRRSetCrtcConfig() fails
  - Prevent a crash with unknown language/country codes
  - Ensure strings from xkeyboard-config are UTF-8
  - Translation updates

28. By Jeremy Bicha

* New upstream release
* debian/control.in:
  - Drop obsolete gnome-doc-utils and scrollkeeper build dependencies

27. By Sebastien Bacher

* debian/patches/git_no_filename_warning.patch:
  - "gnome-bg: objects without a filename are not slideshows",
    that should fix the warnings that are displayed by the appareance
    capplet on start (which are due to solid color backgrounds)

26. By Tim Lunn

* New upstream release
* Sync with Debian (LP: #1184812) Remaining changes:
  - debian/patches:
    + 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    + tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    + git_revert_draw_background.patch
    + ubuntu_language.patch, Ported relevant bits from g-c-c
      52_region_language.patch, as required for gnome 3.8 region panel
    + ubuntu_language_list_from_SUPPORTED.patch,
      adds api to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
  - debian/control.in:
    + Don't break gnome-shell << 3.7.90
    + Use source:Version for gnome-desktop3-data Depend
    + Add epoch to gnome-desktop3-data's Breaks/Replaces, as our old
      gnome-desktop source package introduced an epoch. This needs to be
      kept until after 14.04 LTS.
 - Install helper tools into a versioned directory (by overriding
   libexecdir). They could alternatively be installed in a separate package
* Dropped changes:
  - 02_refuse_to_break_GL_compositors.patch:
    + Doesn't appear to be needed any more

25. By Michael Biebl

Upload to unstable.

24. By Michael Biebl

* Build system-wide help documents and install them in gnome-desktop3-data.
* Add the necessary Breaks/Replaces against gnome-desktop-data (<< 2.32.1-2)
  which previously shipped those files.
* Build gtk-doc API documentation.
* debian/patches/01-clock_gettime.patch: Link libgnome-desktop against librt
  for clock_gettime().
* Use dh-autoreconf to update the build system.
* Update debian/copyright using the machine-readable copyright format 1.0.
* Bump Standards-Version to 3.9.3.
* Set <email address hidden> as Maintainer.

23. By Michael Biebl

* Upload to unstable.
* debian/control.in:
  - Tighten dependency on gnome-desktop3-data again.
  - Change section of gir1.2-gnomedesktop-3.0 to introspection.

22. By Michael Biebl

* Upload to unstable.
* Bump debhelper compatibility level to 8.
* Bump Standards-Version to 3.9.2. No further changes.
* debian/watch: Switch to .bz2 tarballs.

21. By Sebastien Bacher

[ Rico Tzschichholz ]
* debian/{rules,control.in,libgnome-desktop-3-dev,
  gir1.2-gnomedesktop-3.0.install}:
  - enable introspection build and add required files

[ Sebastien Bacher ]
* New upstream version

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/trusty/gnome-desktop3
This branch contains Public information 
Everyone can see this information.

Subscribers