lp:ubuntu/saucy-proposed/gimp

Created by Ubuntu Package Importer on 2013-08-29 and last modified on 2013-08-29
Get this branch:
bzr branch lp:ubuntu/saucy-proposed/gimp
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

24. By Sebastien Bacher on 2013-08-29

* Synchronize with Debian (LP: #1207734). Remaining changes:
  - debian/patches/02_help-message.patch,
    debian/patches/03_gimp.desktop.in.in.patch:
    + Update some strings for Ubuntu
  - debian/control:
    + Update description
  - debian/rules:
    + Set gettext domain and update translation templates

23. By Ari Pollak on 2013-02-23

Imported Upstream version 2.8.4

22. By Ari Pollak on 2012-11-23

* xwd-corruption.patch:
  - Fix memory corruption bug when reading XWD files (Closes: #693977)

21. By Ari Pollak on 2012-09-09

* Imported Upstream version 2.8.2
  - Fixes a security hole in the CEL plugin (Closes: #685397) (CVE-2012-3403)
  - Fixes a security hole in the GIF plugin (CVE-2012-3481)
  - Fixes link failures on on hurd-i386 (Closes: #677342)
  - Fixes incorrect window title after exporting (Closes: #673898)
* Don't overwrite LDFLAGS from dpkg-buildflags

20. By Jordi Mallach on 2012-05-13

[ Jordi Mallach ]
* Use a shlibs.local file to force a dependency on libbabl >= 0.1.10.
  GIMP has an internal check for this version and will refuse to start
  otherwise, as it relies on some optimisations made to babl in
  0.1.8 → 0.1.10 (closes: #672247).

[ Ari Pollak ]
* Add Breaks/Replaces on old gimp-plugin-registry because of conflicting
  file-xmc plugin.

19. By Ari Pollak on 2012-02-18

* Imported Upstream version 2.6.12
* Add ${misc:Depends} variables to packages that were missing it
* Call default versioned python binary instead of just /usr/bin/python

18. By Ari Pollak on 2011-12-22

Really add the patch this time (Closes: #651387)

17. By Ari Pollak on 2011-12-10

poppler0.18.patch: Port file-pdf plugin to poppler 0.18 API. Patch taken from Fedora via Ubuntu.
(Closes: #651387)

16. By Ari Pollak on 2011-11-29

* libpng_compile.patch:
    - Apply patch from upstream to fix compilation with libpng 1.5
      (Closes: #649972)

15. By Ari Pollak on 2011-10-06

* pyslice.patch: upstream patch to fix slice filter crashing (Closes: #644025)
* Apply fix for GIF buffer overflow (CVE-2011-2896) (Closes: #643753)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/saucy/gimp
This branch contains Public information 
Everyone can see this information.

Subscribers