lp:ubuntu/raring/python3-defaults

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/raring/python3-defaults
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

66. By Matthias Klose

Bump version to 3.3.1.

65. By Dmitry Shachnev

* Merge with Debian experimental, remaining changes:
  - Drop python3.2 as a supported python3 version.
  - Make python3-{all,all-dev,all-dbg} Multi-Arch: allowed.
  - Move debiandoc-sgml and lsb-release from Build-Depends-Indep to
    Build-Depends.
  - Build libpython3-all-{dev,dbg} and libpython3-stdlib packages.
  - Build-depend on python:any instead of python.

64. By Matthias Klose

Build-depend on python:any instead of python.

63. By Matthias Klose

Build a libpython3-stdlib package.

62. By Matthias Klose

python3{,-all}-{dev,dbg}: Depend on libpython3{,-all}-{dev,dbg}.

61. By Matthias Klose

Build libpython3.3-all-{dev,dbg} packages.

60. By Dmitry Shachnev

[ Piotr O┼╝arowski ]
* pybuild:
  - add --ext-dest-dir (PYBUILD_EXT_DESTDIR) and --ext-pattern
    (PYBUILD_EXT_PATTERN) options to move files after install step
  - save before/after command logs if quiet mode is on
  - do not warn about limiting versions if there's only one
* dh_python3: add version range to py3compile in maintainer scripts

[ Dmitry Shachnev ]
* Merge with Debian packaging bzr r259. Remaining changes:
  - Drop python3.2 as a supported python3 version.
  - Make python3-{all,all-dev,all-dbg} Multi-Arch: allowed.
  - Move debiandoc-sgml and lsb-release from Build-Depends-Indep to
    Build-Depends.
* Include architecture.mk in debian/rules instead of defining
  DEB_HOST_* manually.
* tests/t1: Build-depend on python3-all instead of python-all.
* Make tests work without python-support installed.
* debian/tests/control: Add a dependency on libjs-jquery (test1 contains
  a symlink to /usr/share/javascript/jquery/jquery.js).

59. By Scott Kitterman

[ Piotr O┼╝arowski ]
Interpreter._get_config: try distutils.sysconfig for older Python
versions, use sysconfig for Version('3')

58. By Matthias Klose

Fix merge error, drop python3.2 from the supported versions.

57. By Matthias Klose

Move debiandoc-sgml, python-docutils, lsb-release to Build-Depends.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers