lp:ubuntu/raring-proposed/python-qt4

Created by Ubuntu Package Importer on 2012-11-26 and last modified on 2013-04-08
Get this branch:
bzr branch lp:ubuntu/raring-proposed/python-qt4
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

95. By Jonathan Riddell on 2013-04-08

Update fix-QTextBlockUserData.patch with fix from upstream
to allow PyKDE to compile (LP: #1161818)

94. By Julian Taylor on 2013-03-29

backport fix-QTextBlockUserData.patch from upstream snapshot
fixes e.g. syntax highlighting in editors (LP: #1161818)

93. By Scott Kitterman on 2013-03-06

* New upstream release
  - Refresh patches
  - Bump minimum required sip4 build-dep versions to 4.14.4
* Backport upstream fix for invisibleRootItem bug from 20130305, changeset
  85635bd2f453

92. By Dimitri John Ledkov on 2013-01-07

* Fix compiling Qt Designer plugin with multiarched python.
* Unify build targets across py2 & 3, both now multiarched.
* Enable DEB_BUILD_OPTIONS compliant parallel build.

91. By Matthias Klose on 2012-11-08

Rebuild to drop python3.2 extension.

90. By Scott Kitterman on 2012-10-26

Fix version specific pyqtconfig imports

89. By Scott Kitterman on 2012-10-25

* Adjust pyqtconfig.py references in debian/python3-pyqt4.install to cover
  all variants now shipped
* Fix find command in install-arch so pyqtconfig files for debug packages
  aren't removed
* Additional minor cleanups to get files installed properly for pyqtconifg
   and .so files in python3-dbus.mainloop.qt/-dbg

88. By Steve Langasek on 2012-10-24

[ Scott Kitterman ]
* Add debian/patches/config_extra_headers.diff so additional header
  directories used in python3.3 due to multiarch are found during build
* Update debian/rules to account for different layout of python3.3 due to
  multiarch
* Update python3-all-dev minimum version due to bug fixes in 3.2.3-6 for
  building with multiple python3 versions
* Generate a multi-version pyqtconfig.py for python3 variants to account
  for multiple files installed into the same directory as is done with
  sipconfig in python3-sip

[ Steve Langasek ]
* Fine adjustments to debian/rules

87. By Scott Kitterman on 2012-07-24

Add -N pyqt4-dev-tools to the dh_python3 invocation so dh_pyton3 will
leave pyqt4-dev-tools alone and not rewrite it's shebang to
/usr/bin/python3 (Closes: 682623)

86. By Scott Kitterman on 2012-07-14

Add debian/patches/pyuic_custom_widget.diff from upstream to fix custom
widget detection and prevent other packages from FTBFS (Closes: #680837)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/raring/python-qt4
This branch contains Public information 
Everyone can see this information.

Subscribers