lp:ubuntu/raring/nautilus-image-manipulator

Created by James Westby on 2012-10-20 and last modified on 2013-03-02
Get this branch:
bzr branch lp:ubuntu/raring/nautilus-image-manipulator
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

10. By Emilien Klein on 2013-03-02

* Fix 2 upstream bugs, patches already applied upstream and released in v1.2:
  - debian/patches/fix-702044: Corrupted config file if width/height are
      defined from keyboard (Closes: #702044)
  - debian/patches/fix-702045: Upload to 1fichier.com not working
      (Closes: #702045)

9. By Salvatore Bonaccorso on 2012-06-26

* Non-maintainer upload.
* Set temporary writable $HOME directory during build.
  Fix FTBFS "IOError: [Errno 2] No such file or directory:
  '/sbuild-nonexistent/.nautilus-image-manipulator.ini'". (Closes: #676045)

8. By Emilien Klein on 2012-05-05

* New upstream release
* debian/watch:
  - Downloading the tarball from Launchpad now goes through https
* debian/control:
  - Changed the Vcs-* fields to point to the repository used to maintain
    the Debian package instead of the upstream repository
  - Bump Standards-Version to 3.9.3
  - Add python-gobject to Depends
  - Add python-gobject, python-nose, python-imaging and python-pyexiv2 to
    Build-Depends
  - Updated the description to highlight changes coming with version 1.0.
    Also removed the reference to Nautilus Image Converter as the two
    projects are now very different
* debian/rules:
  - Added override_dh_auto_test to run the nose tests
* debian/nautilus-image-manipulator.manpages:
  - The directory containing the manpage has been renamed: 'doc' => 'docs'
* debian/patches/nosetests.patch:
  - Added patch to properly handle translated strings in nose tests.
    Already included upstream (r188)

7. By Emilien Klein on 2012-02-14

* New upstream release
* debian/control:
  - Do not depend on imagemagick anymore
  - Depend on python-imaging and python-pyexiv2

6. By Emilien Klein on 2011-12-15

* Remove included Poster source code and instead use the python-poster
    package from Debian (Closes: #648030) (LP: #761146)
* debian/control:
  - Require python-poster 0.8.0 or higher

5. By Emilien Klein on 2011-10-26

* New upstream release
  - Transition to Nautilus 3 and GObject introspection
    (Closes: #644694) (LP: #859104 and LP: #849361).
* debian/control:
  - Require python-nautilus 1.1 or higher
  - Depend on gir1.2-gtk-3.0, gir1.2-glib-2.0, gir1.2-nautilus-3.0
  - Remove build dependency on pkg-config and python-nautilus
* debian/watch:
  - Add `debian uupdate` after the URL
* debian/copyright:
  - Conform to DEP-5: Machine-readable debian/copyright

4. By Daniel T Chen on 2011-09-12

No-change rebuild for newer GNOME libs. (LP: #836601)

3. By Emilien Klein on 2011-05-17

New upstream release

2. By Emilien Klein on 2011-04-14

Initial release (Closes: #611690)

1. By Emilien Klein on 2011-04-14

Import upstream version 0.2

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers