lp:ubuntu/raring/alsa-plugins

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/raring/alsa-plugins
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

55. By Reinhard Tartler

* add new patch fix-ftbfs-libav9.patch:
   - Fix FTBFS with Libav9 Update to newer libav API - compatible to
     libav 0.8 and libav 9 (LP: #1076011)

54. By Luke Yelavich

* debian/control: Update Vcs-Bzr field for raring
* debian/patches/usb_stream-Fix-build-with-glibc-2.16.patch: Fix FTBFS,
  thanks to Reinhard Tartler (LP: #1075718)

53. By Luke Yelavich

* Merge from debian unstable, remaining changes:
  - Create libasound2-plugins-extra package which contains plugins that use
    libav.

52. By Luke Yelavich

* Move all lavcrate plugins to the extra package that were missed in the
  previous upload. This will ensure that libasound2-plugins will not depend
  on anything to do with libav.
* Add Pre-Depends bits for multi-arch. (LP: #1015982)

51. By Luke Yelavich

[ Mike Mestnik ]
* Add build depend on libavcodec-dev and libavutil-dev
* Split the a52 plugin out to it's own package. (LP: #197957)

[ Luke Yelavich ]
* debian/control: Adjust Vcs-Bzr field for quantal.
* Ship the lavcrate plugin in the libasound2-plugins-extra package.

50. By Luke Yelavich

* Merge from debian unstable, remaining changes:
  - Do not build-depend on libavcodec-dev and libavutil-dev
  - Add Vcs-Bzr field

49. By Luke Yelavich

* Merge from debian unstable, remaining changes:
  - Do not build-depend on libavcodec-dev
  - drop lib32asound2-plugins
  - tighten dependencies on lib*asound2-dev and libpulse-dev
  - Add Vcs-Bzr field
  - Do not build bi-arch packages on ppc64
  - Build with LDFLAGS=-Wl,-z,defs to prevent accidentally building modules
    with undefined symbols.
  - link arcam-av module against libpthread.
  - Use new pulseaudio API

48. By David Henningsson

Use the new PulseAudio API for better underrun handling (LP: #805940)

47. By Steve Langasek

* Build with LDFLAGS=-Wl,-z,defs to prevent accidentally building modules
  with undefined symbols.
* debian/patches/arcam-av_uses_pthreads.patch: link arcam-av module
  against libpthread.
* drop upstream cherry picks 5f5cde5 and 440e791: these rely on a new
  symbol, snd_pcm_open_fallback, which is not available in the currently
  available upstream release of alsa-lib, so cherry-picking these patches
  simply made the pulseaudio module stop working altogether.

46. By Luke Yelavich

* Cherry-pick some fixes from git master:
  - 21f6686 (jack: Fix hanging applications when using jack plugin)
  - 440e791 (pulse: Set PA_CONTEXT_NOAUTOSPAWN when fallback is available)
  - 5f5cde5 (pulse: Add fallback option)
  - e1661e3 (Pulse: Fix snd_pcm_avail returning 0 in some cases)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/alsa-plugins
This branch contains Public information 
Everyone can see this information.

Subscribers