lp:ubuntu/quantal/xen

Created by Ubuntu Package Importer on 2012-04-26 and last modified on 2012-10-15
Get this branch:
bzr branch lp:ubuntu/quantal/xen
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

30. By Stefan Bader on 2012-09-27

* Merge from Debian unstable. Remaining changes:
  - libxenstore3.0: Conflict and replaces libxen3.
  - libxen-dev: Conflict and replaces libxen3-dev.
  - xenstore-utils: Conflict and replaces libxen3.
  - xen-utils-4.1: Conflict and replaces libxen3, python-xen-3.3,
    and xen-utils-4.1.
  - Change depend back to ipxe as we do not have ipxe-qemu.
  - etherboot: Change the config back to include the 8086100e.rom
  - Dropped:
    - Make sure the LDFLAGS value passed is suitable for use by ld
      rather than gcc. Right now there seem to be no LDFLAGS passed.
* Backported AMD specific improvements from upstream Xen (LP: #1009098):
  - svm: Do not intercept RDTSC(P) when TSC scaling is supported by hardware
  - x86: Use deep C states for off-lined CPUs
  - x86/AMD: Add support for AMD's OSVW feature in guests.
  - hvm: vpmu: Enable HVM VPMU for AMD Family 12h and 14h processors

29. By Chuck Short on 2012-07-03

[ Ubuntu Merge-o-Matic ]
* Merge from Debian unstable. Remaining changes:
    - Thanks to Stefan Bader.
    - libxenstore3.0: Conflict and replaces libxen3.
    - libxen-dev: Conflict and replaces libxen3-dev.
    - xenstore-utils: Conflict and replaces libxen3.
    - xen-utils-4.1: Conflict and replaces libxen3, python-xen-3.3,
      and xen-utils-4.1.
    - Change depend back to ipxe as we do not have ipxe-qemu.
    - etherboot: Change the config back to include the 8086100e.rom
    - Dropped:
      - Make sure the LDFLAGS value passed is suitable for use by ld
        rather than gcc. Right now there seem to be no LDFLAGS passed.

28. By Stefan Bader on 2012-03-06

etherboot: Change the config back to include the 8086100e.rom
(LP: #948333)

27. By Chuck Short on 2011-12-22

* Merge from Debian testing. Remaining changes:
    - libxenstore3.0: Conflict and replaces libxen3.
    - libxen-dev: Conflict and replaces libxen3-dev.
    - xenstore-utils: Conflict and replaces libxen3.
    - xen-utils-4.1: Conflict and replaces libxen3, python-xen-3.3,
      and xen-utils-4.1.
    - Make sure the LDFLAGS value passed is suitable for use by ld
      rather than gcc.
    - Dropped:
      - debian/patches/upstream-23044:d4ca456c0c25
      - debian/patches/upstream-23104:1976adbf2b80
      - debian/patches/upstream-changeset-23146.patch
      - debian/patches/upstream-changeset-23147.patch
      - debian/patches/xen-pirq-resubmit-irq.patch

26. By Chuck Short on 2011-11-06

* Merge from Debian testing. Remaining changes:
    - libxenstore3.0: Conflict and replaces libxen3.
    - libxen-dev: Conflict and replaces libxen3-dev.
    - xenstore-utils: Conflict and replaces libxen3.
    - xen-utils-4.1: Conflict and replaces libxen3, python-xen-3.3,
      and xen-utils-4.1.
    - Make sure the LDFLAGS value passed is suitable for use by ld
      rather than gcc.
    - debian/patches/upstream-changeset-23146.patch,
      debian/patches/upstream-changeset-23147.patch: Fix booting with hvm
      domU. (LP: #832207)
    - debian/patches/xen-pirq-resubmit-irq.patch: Retrigger pirq events
      when asserted while processing. (LP: #854829)

25. By Chuck Short on 2011-10-10

debian/patches/xen-pirq-resubmit-irq.patch: Retrigger
pirq events when asserted while processing. Thanks to Stefan Bader
(LP: #854829)

24. By Matthias Klose on 2011-10-06

Rebuild to drop build records on armel and powerpc. LP: #823714.

23. By Matthias Klose on 2011-10-06

Rebuild to drop build records on armel and powerpc. LP: #823714.

22. By Chuck Short on 2011-09-01

* Clean up patches.
* debian/patches/upstream-changeset-23146.patch,
  debian/patches/upstream-changeset-23147.patch: Fix booting with hvm
  domU. (LP: #832207)

21. By Chuck Short on 2011-08-11

* Merge from debian unstable. Remaining changes:
    - libxenstore3.0: Conflict and replaces libxen3.
    - libxen-dev: Conflict and replaces libxen3-dev.
    - xenstore-utils: Conflict and replaces libxen3.
    - xen-utils-4.1: Conflict and replaces libxen3, python-xen-3.3,
      and xen-utils-4.1.
  + Make sure the LDFLAGS value passed is suitable for use by ld
    rather than gcc.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/raring/xen
This branch contains Public information 
Everyone can see this information.

Subscribers