lp:ubuntu/quantal/wxwidgets2.8

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/quantal/wxwidgets2.8
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

41. By Colin Watson

Build-depend on libtiff-dev rather than libtiff4-dev.

40. By Benjamin Drung

Drop appmenu workaround. It causes 100% CPU usage when using
appmenu. (LP: #996407)

39. By Benjamin Drung

* Merge from Debian unstable. Remaining changes:
  - debian/rules: re-enable mediactrl. This allows libwx_gtk2u_media-2.8 to be
    built, as this is required by some applications (LP: #632984)
  - debian/control:
    - Build-dep on libxt-dev, libgstreamer-plugins-base0.10-dev,
      and libgconf2-dev for mediactrl.
    - Add conflict on python-wxgtk2.8 (<< 2.8.12.1-6ubuntu1~) to
      python-wxversion to guarantee upgrade ordering when moving from
      pycentral to dh_python2.
* Drop fix-bashism-in-example.patch. (LP: #1005609)

38. By Benjamin Drung

* Merge from Debian unstable. Remaining changes:
  - debian/rules: re-enable mediactrl. This allows libwx_gtk2u_media-2.8 to be
    built, as this is required by some applications (LP: #632984)
  - debian/control:
    - Build-dep on libxt-dev, libgstreamer-plugins-base0.10-dev,
      and libgconf2-dev for mediactrl.
    - Add conflict on python-wxgtk2.8 (<< 2.8.12.1-6ubuntu1~) to
      python-wxversion to guarantee upgrade ordering when moving from
      pycentral to dh_python2.
  - Patches
    + fix-bashism-in-example.patch
* Backport patch to fix calling SetMenuBar() twice causes the menubar to not
  resize correctly in GTK. (LP: #996407)

37. By Fabrice Coutadeur

debian/control: add b-d on libgstreamer-plugins-base0.10-dev and
libgconf2-dev to fully enable mediactrl and build libwx_gtk2u_media-2.8
(LP: #928894)

36. By St├ęphane Graber

* Resync from Debian, changes that were kept:
  - debian/rules: re-enable mediactrl. This allows libwx_gtk2u_media-2.8 to be
    built, as this is required by some applications (LP: #632984)
  - debian/control: Build-dep on libxt-dev for mediactrl.
  - Patches
    + fix-bashism-in-example
* Add conflict on python-wxgtk2.8 (<< 2.8.12.1-6ubuntu1~) to python-wxversion
  to guarantee upgrade ordering when moving from pycentral to dh_python2.

35. By Colin Watson

Build-depend on libjpeg-dev rather than libjpeg62-dev.

34. By Steve Langasek

debian/patches/multiarch_paths.patch: look in the multiarch path
when detecting libraries. Closes LP: #828999.

33. By Fabrice Coutadeur

debian/rules: reenable mediactrl. This allows libwx_gtk2u_media-2.8 to be
built, as this is required by some applications (LP: #632984)

32. By David Henningsson

debian/patches/appmenu2.patch: Fix high CPU usage with
appmenu-gtk, which was caused by appmenu.path (LP: #722375)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/raring/wxwidgets2.8
This branch contains Public information 
Everyone can see this information.

Subscribers