lp:ubuntu/quantal/libwww-perl

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/quantal/libwww-perl
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

26. By Alessandro Ghedini

* Team upload
* New upstream release

25. By Nicholas Bamber

[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.

[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
  svn.debian.org to anonscm.debian.org URL.

[ Nicholas Bamber ]
* New upstream release
* Added override for DEP-5 format lintian warning
* Raised debhelper version and compat level to 8
* Downgraded libauthen-ntlm-perl to Suggests in sympathy with Ubuntu

24. By Matthias Klose

Suggest libauthen-ntlm-perl (universe) instead of recommending it.
See LP: #787495.

23. By Nicholas Bamber

[ Nicholas Bamber ]
* New upstream release
  - Split off LWP::Protocol::https
  - Removes need for patch
  - Removes deprecated modules such as http10
* Added Recommends clause for libauthen-ntlm-perl
* Updated version in Breaks clause for tidy-proxy
* Updated version in Breaks clause for gsutil
* Raised standards version to 3.9.2
* Adding debian/clean

[ gregor herrmann ]
* debian/rules: unset PERL_LWP_SSL_VERIFY_HOSTNAME to make tests pass.
* Removed libio-socket-ssl-perl, libcrypt-ssleay-perl from Suggests clause

22. By Nicholas Bamber

Add versioned Breaks clauses for packages which use HTTP::Daemon
or HTML::Form (Closes: #621135)

21. By gregor herrmann

Fix "typo in depends makes package uninstallable":
s/ca-certficates/ca-certificates/.
Thanks to Michael Biebl for the bug report (closes: #621019).

20. By Nicholas Bamber

* New upstream release
  - Modules not in the LWP namespace have been made into separate modules
  - In particular IPv6 issues now handled by libnet-http-perl,
    see #306914, (Closes: #614948)
  - Packages using HTTP::Daemon should declare the appropriate
    dependency on libhttp-daemon-perl | libwww-perl (<< 6).
  - Packages using HTML::Form should declare the appropriate
    dependency on libhtml-form-perl | libwww-perl (<< 6).
  - Other depending packages can safely continue to depend on libwww-perl,
    but in some cases may be able to tighten up their dependencies.
  - LWP::Protocol::https will be split off in the next release
    so now liblwp-protocol-https-perl is Provided.
* Updated dependencies
* New upstream release
* Removed unnecessary versioned dependency on libio-compress-perl
* Patched LWP::Protocol::https to use ca-certificates rather than
  Mozilla::CA (Closes: #619059)

19. By Nicholas Bamber

* New upstream release
* Added myself to Uploaders and upped standards version
* Fixed erroneous copyright date of 2017 in changelog
* Refreshed copyright
* Rewrote the short description

18. By Jonathan Yu <email address hidden>

New upstream release

17. By Jonathan Yu <email address hidden>

* New upstream release
* Use new 3.0 (quilt) source format
* Standards-Version 3.8.4 (no changes)
* Update copyright to new DEP5 format

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/raring/libwww-perl
This branch contains Public information 
Everyone can see this information.

Subscribers