lp:ubuntu/precise/vlc

Created by James Westby on 2011-10-13 and last modified on 2012-03-30
Get this branch:
bzr branch lp:ubuntu/precise/vlc
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

114. By Benjamin Drung on 2012-03-30

Add missing Breaks and Replaces for moving the documentation from vlc-data
away from /usr/share/doc/vlc before converting the directory into a symlink.
(Closes: #665743)

113. By Benjamin Drung on 2012-03-28

Replace symlink by directory in /usr/share/doc/vlc-nox.
(Closes: #665743, LP: #964449)

112. By Benjamin Drung on 2012-03-24

Really add the preinst from Didier Raboud to vlc to drop it's doc directory
before unpacking a symlink to vlc-nox's over it. (Closes: #613121, #662217)

111. By Benjamin Drung on 2012-02-28

* Enable and install Open Sound System (OSS) plugin.
* Fix configure flag from --enable-libv4l2 to --enable-v4l2.

110. By Benjamin Drung on 2012-02-26

* Remove nasm and yasm form build dependencies (they are not used).
* Bump Standards-Version to 3.9.3, no changes needed.
* Backport patch from upstream to the fix build failures on kfreebsd.
  (Closes: #660935)
* altivec-cflags.patch: Add missing CFLAGS_* variables to pass the "-maltivec"
  flag. This should fix the build failure on powerpc. (Closes: #660936)

109. By Benjamin Drung on 2012-02-18

* New upstream release (Closes: #499381, #573064, #624027, LP: #455825,
  #573775, #695882, #705151, #708448, #738381, #743581, #747757, #817924,
  #931083).
* Remove dropped mozilla-plugin-vlc, vlc-plugin-ggi, and vlc-plugin-svgalib.
  The Mozilla browser plug-in is now provided by a separate source tarball.
* Add new plugins to and remove dropped plugins from vlc-nox.
* Add new and remove dropped build dependencies:
  + libbluray-dev (for Blu-ray support)
  + libresid-builder-dev
  + libsamplerate0-dev
  + libsidplay2-dev
  + lbspeexdsp-dev
  + libxcb-composite0-dev
  - libgtk2.0-dev
  - xulrunner-dev
* vlc-plugin-fluidsynth depends on fluid-soundfont-gm or
  musescore-soundfont-gm for having a sound font for playing MIDI files.
* Drop all patches (they were either backported or accepted by upstream).
* Update symbols for libvlc5.
* Install plugins.dat instead of running vlc-cache-gen in postinst.
* Update minimum version of build dependencies.
* Change Build-Dependency from libupnp3-dev to unversioned libupnp-dev.
  (Closes: #656831)

108. By Martin Pitt on 2012-02-16

No-change rebuild against libproxy1.

107. By Benjamin Drung on 2012-02-13

* New upstream release (Closes: #499381, #573064, #624027, LP: #455825,
  #573775, #695882, #705151, #708448, #738381, #743581, #747757, #817924,
  #931083).
* Remove dropped mozilla-plugin-vlc, vlc-plugin-ggi, and vlc-plugin-svgalib.
  The Mozilla browser plug-in is now provided by a separate source tarball.
* Add new plugins to and remove dropped plugins from vlc-nox.
* Add new and remove dropped build dependencies:
  + libbluray-dev (for Blu-ray support)
  + libresid-builder-dev
  + libsamplerate0-dev
  + libsidplay2-dev
  + lbspeexdsp-dev
  + libxcb-composite0-dev
  - libgtk2.0-dev
  - xulrunner-dev
* vlc-plugin-fluidsynth depends on fluid-soundfont-gm or
  musescore-soundfont-gm for having a sound font for playing MIDI files.
* Drop all patches (they were either backported or accepted by upstream).
* Update symbols for libvlc5.
* Install plugins.dat instead of running vlc-cache-gen in postinst.
* Update minimum version of build dependencies.
* Change Build-Dependency from libupnp3-dev to unversioned libupnp-dev.
  (Closes: #656831)

106. By Angel Abad on 2012-01-22

No changes rebuild for libx264-120 transition

105. By Angel Abad on 2012-01-09

No changes rebuild for libcdio13 transition

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/vlc
This branch contains Public information 
Everyone can see this information.

Subscribers