lp:ubuntu/precise/qemu-linaro

Created by James Westby on 2011-10-13 and last modified on 2012-04-22
Get this branch:
bzr branch lp:ubuntu/precise/qemu-linaro
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

12922. By Colin Watson on 2012-04-22

releasing version 1.0.50-2012.03-0ubuntu2

12921. By Colin Watson on 2012-04-22

Add missing #include that caused a build failure on powerpc.

12920. By Steve Langasek on 2012-03-15

* Update watch file since launchpad now uses https for the download links.
* New upstream release.
  - Fixes use of deprecated gthread calls when building on arm.
    LP: #928555.
* Drop 0001_linux-user-reserve-4GB-of-vmem-for-32-on-64.patch, included
  upstream with some follow-on fixes.

12919. By Steve Langasek on 2012-02-20

* New upstream release.
* Pass --enable-uname-release=2.6.32 for the user emulation builds, so that
  we have a sensible baseline kernel value regardless of what the
  underlying host kernel is. This makes eglibc happier when running under
  emulation on a very old kernel for instance (whose host syscall ABI has
  nothing to do with what emulated syscalls are supported), and probably
  also lets us steer clear for the moment of code that has problem with
  the new kernel upstream versioning convention. LP: #921078.
* debian/patches/define_AT_EMPTY_PATH.patch: make sure AT_EMPTY_PATH
  is defined. Thanks to Serge Hallyn <email address hidden>.
  Closes LP: #930181.

12918. By Loïc Minier on 2012-02-17

New patch, 0001_linux-user-reserve-4GB-of-vmem-for-32-on-64, from
http://lists.gnu.org/archive/html/qemu-devel/2011-12/msg01697.html; fixes
mmap when running a 32-bits guest on a 64-bits host; LP: #906922.

12917. By Steve Langasek on 2012-02-07

* Don't build the qemu-kvm-spice package on i386, spice is 64-bit-only.
  LP: #928432.
* This means we don't have to disable -Werror on the spice build anymore.

12916. By Steve Langasek on 2012-02-07

* Turn off -Werror for the spice build: the spice API uses a 64-bit
  integer type for storing pointers even on 32-bit systems, leading to
  warnings about wrong casts that we can safely ignore here. LP: #926195.
* Pass --disable-spice to the system build, otherwise it ends up having
  spice enabled as well.

12915. By Steve Langasek on 2012-02-02

New upstream release.

12914. By Steve Langasek on 2011-12-14

New upstream release.

12913. By Steve Langasek on 2011-12-06

* New upstream release.
  - fixes segfaults of aptitude under qemu-arm-static. LP: #898474.
* debian/patches/1-tcg-ppc-tcg-target.c-Avoid-set-but-not-used-gcc-warn.patch:
  drop, addressed upstream.
* Drop use of -Wno-error=deprecated-declarations build option, no longer
  needed for gnutls compatibility.

[ Serge Hallyn ]
* Add qemu-kvm-spice package
  - debian/control: add libspice-protocol-dev and libspice-server-dev
    to build-depends, define the qemu-kvm-spice package,
    remove all other packages, and rename source package to qemu-kvm.
  - debian/rules:
    * keep only spice-enabled binaries
    * rename our binaries to '-spice'
  - debian/qemu-kvm-spice.links and debian/qemu-kvm-spice.install: install
    kvm-spice and qemu-system-x86_64-spice

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/qemu-linaro
This branch contains Public information 
Everyone can see this information.

Subscribers