lp:ubuntu/precise-proposed/python2.7

Created by Ubuntu Package Importer on 2012-04-22 and last modified on 2014-12-18
Get this branch:
bzr branch lp:ubuntu/precise-proposed/python2.7
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

61. By James Page on 2014-12-18

* Ensure failed connections to /dev/log are full closed, preventing
  infinite loop on logging applications due to socket state (LP: #1081022):
  - d/p/syslog.diff: Cherry picked fix from upstream bugtracker.

60. By Barry Warsaw on 2013-06-07

debian/patches/atomic-pyc-rename.diff: Add patch to fix possible race
conditions when writing .pyc/.pyo files in py_compile.py.
Issue #13146. LP: #1058884

59. By Matthias Klose on 2013-03-28

* Backport fix for issue #14308. Fix an exception when a "dummy" thread is
  in the threading module's active list after a fork(). LP: #1100343.
* Remove dangling symlink in pkgconfig. LP: #1088771.
* Make python2.7{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.

58. By Scott Kitterman on 2012-07-27

Cherry pick af46a001d5ec to remove Python syslog BOM insertion code that
was causing corrupt log messages in syslog. LP: #1029640

57. By Steve Langasek on 2012-04-20

* python2.7-minimal needs a versioned depends on python-minimal, not a
  Conflicts. Conflicts with essential packages, versioned or otherwise,
  are a serious problem for upgrades, as the previous upload demonstrated.
  Instead, we allow a circular dependency between python2.7-minimal and
  python-minimal, and rely on the fact that the package manager ensures
  new versions of both packages will be unpacked before running the
  maintainer script from python2.7-minimal. LP: #986374.
* Our versioned dependency on python-minimal is 2.6.6-3+squeeze1, which is
  the first version shipping a pycompile that supports passing a -V option
  referring to a version python-minimal doesn't already know about.

56. By Matthias Klose on 2012-04-19

python2.7-minimal: Conflict with python-minimal (<< 2.7.3). LP: #983981.

55. By Matthias Klose on 2012-04-10

Python 2.7.3 release.

54. By Matthias Klose on 2012-04-06

Merge with Debian; remaining changes:

53. By Matthias Klose on 2012-03-21

* Loosen build dependency on expat (the version in precise has the
  security fixes applied).
* Add safety check to ensure that the _bsddb extension is built.

52. By Steve Langasek on 2012-03-09

Re-enable the db5.1 patch again. LP: #440889.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/python2.7
This branch contains Public information 
Everyone can see this information.

Subscribers