lp:ubuntu/precise/python-boto

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/precise/python-boto
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

28. By Dave Walker on 2012-03-05

* Switch to dpkg-source 3.0 (quilt) format
* debian/patches/import-boto-provider.patch: New patch that resolves issue
  of boto/utils.py making calls to function boto.provider, without importing
  it. LP: #947424

27. By Scott Moser on 2012-02-15

releasing version 2.2.2-0ubuntu1

26. By Scott Moser on 2012-02-15

* New upstream release (LP: #932795)
* update debian/watch to point to github downloads instead of google code

25. By Scott Moser on 2012-02-15

update debian/watch to look at github rather than google code

24. By Scott Moser on 2012-02-13

releasing version 2.2.1-0ubuntu1

23. By Scott Moser on 2012-02-10

New upstream release.
 Note: tests are back in the tarball

22. By Scott Moser on 2011-12-07

releasing version 2.1.1-0ubuntu1

21. By Scott Moser on 2011-12-07

* New upstream release.
* Remaining changes from debian:
  - debian/watch: fix for mangled versions (#650480)
* Dropped delta (included upstream):
  - boto/auth.py: use email.utils.formatdate(usegmt=True) instead of strftime
    as the latter breaks when boto is used from application setting up
    locales (like bpython or ipython); upstream issue #140.

20. By Loïc Minier on 2011-11-30

Release 2.0-2ubuntu1 to precise

19. By Scott Moser on 2011-11-30

* Sync with debian.
* Remaining changes from debian:
  - debian/watch: fix for mangled versions (#650480)
* Changes from upstream:
  - boto/auth.py: use email.utils.formatdate(usegmt=True) instead of strftime
    as the latter breaks when boto is used from application setting up
    locales (like bpython or ipython); upstream issue #140.
* Dropped delta:
  - debian/rules: Run testsuite during build but ignore failures
    since it currently doesn't pass.
  - debian/rules, debian/control: Transition from pysupport to dh_python2
    (LP: #788514)
  - debian/rules:
    + README removed (no longer in source tarball)
    + doc install of cq.py removed (it is now installed to /usr/bin)
* Promote new upstream to unstable (Closes: #638931).
* New upstream release.
* Convert packaging to dh_python2 (Closes: #631430).
* Updated to Debian Policy version 3.9.2.
* Patched to include Python 2.7 in httplib work-around for https
  signatures. Thanks Matthias Klose. (Closes: #607120)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/python-boto
This branch contains Public information 
Everyone can see this information.

Subscribers