lp:ubuntu/precise/perl

Created by James Westby on 2011-10-13 and last modified on 2012-03-23
Get this branch:
bzr branch lp:ubuntu/precise/perl
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

65. By Steve Langasek on 2012-03-23

releasing version 5.14.2-6ubuntu2

64. By Steve Langasek on 2012-03-23

Have perl, perl-modules, and perl-base conflict with versions of
mono-gac requiring File::Basename, to ensure a smooth upgrade from lucid.
LP: #948848.

63. By Martin Pitt on 2011-12-16

debian/control: Add doc-base conflict also to perl, perl-modules, and
libperl5.14. Otherwise they can get unpacked before upgrading perl-base
and doc-base and thus still cause symbol lookup errors in the doc-base
trigger. (Closes: #648954, LP: #902553)

62. By Dominic Hargreaves on 2011-11-28

[ Niko Tyni ]
* debian/rules: correctly handle subject line wraps in patch headers.

[ Dominic Hargreaves ]
* Add versioned Conflicts on update-inetd (<< 4.41) (Closes: #649177)
* Conflict on rather than Break doc-base (<< 0.10.3); aptitude
  runs doc-base triggers before the new version has been unpacked
* Update Lintian override for perl-module-uses-perl4-libs-without-dep
  to reflect new path to CGI.pm
* Disable various tests which fail on GNU/Hurd (see #648623)

61. By Colin Watson on 2011-11-24

releasing version 5.14.2-5ubuntu1

60. By Colin Watson on 2011-11-24

update Maintainer for Ubuntu

59. By Colin Watson on 2011-11-24

Break older versions of update-inetd to avoid File::Temp and File::Copy
binary-incompatibility issues during upgrades (LP: #862129).

58. By Dominic Hargreaves on 2011-11-17

* Update versioned Breaks for dual-lived modules with updates in
  5.14.2 (libmodule-corelist-perl, libencode-perl)
* Update versioned Breaks for doc-base to << 0.10.3; this version
  improves the resilience of the postinst during a major perl upgrade
  (Closes: #648954)

57. By Dominic Hargreaves on 2011-11-15

Add Conflicts: libjson-pp-perl (<< 2.27200-2) to perl package
to fix file conflict with dual-lived module (Closes: #648897)

56. By Colin Watson on 2011-11-15

Rebuild in the main archive to avoid depending on an experimental libc6.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/perl
This branch contains Public information 
Everyone can see this information.

Subscribers