lp:ubuntu/precise-updates/openvpn

Created by Ubuntu Package Importer on 2013-03-28 and last modified on 2014-12-01
Get this branch:
bzr branch lp:ubuntu/precise-updates/openvpn
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

51. By Marc Deslauriers on 2014-12-01

* SECURITY UPDATE: server denial of service via too-short control channel
  packets
  - debian/patches/CVE-2014-8104.patch: drop too-short control channel
    packets instead of asserting out in ssl.c.
  - CVE-2014-8104
* debian/patches/update_certs.patch: update test certs to fix FTBFS.

50. By Marc Deslauriers on 2014-09-30

* SECURITY UPDATE: timing attack when using UDP mode
  - debian/patches/CVE-2013-2061.patch: use constant time memcmp when
    comparing HMACs in crypto.c, added warning to buffer.h.
  - CVE-2013-2061

49. By St├ęphane Graber on 2012-03-30

* Merge at Simon Deziel's request to build with PIE.
* Merge from Debian unstable. Remaining changes:
  + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()

48. By St├ęphane Graber on 2012-02-25

* Merge from Debian unstable. Remaining changes: (LP: #907828)
  + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()

47. By Chuck Short on 2011-12-31

* Merge from Debian testing. Remaining changes:
 + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()
  + debian/update-resolv-conf: Support multiple domains.
  + fix bug where '--script-security 2' would be passed for all
    daemons after the first. (LP: #794916)

46. By Chuck Short on 2011-06-16

* Merge from debian unstable. Remaining changes:
 + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()
  + debian/update-resolv-conf: Support multiple domains.
  + fix bug where '--script-security 2' would be passed for all
    daemons after the first. (LP: #794916

45. By Scott Moser on 2011-06-09

[Alexander Zielke]
fix bug where '--script-security 2' would be passed for all
daemons after the first. (LP: #794916)

44. By Chuck Short on 2011-05-17

* Merge from debian unstable. Remaining changes:
 + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()
  + debian/update-resolv-conf: Support multiple domains.

43. By Chuck Short on 2011-03-22

* Merge from debian unstable. Remaining changes:
  + debian/openvpn.init.d:
    - Do not use start-stop-daemon and </dev/null to avoid blocking boot.
    - Show per-VPN result messages.
    - Add "--script-security 2" by default for backwards compatabliity.
  + debian/control: Add lsb-base >= 3.2-14 to allow status_of_proc()
  + debian/update-resolv-conf: Support multiple domains.

42. By Dave Walker on 2011-03-11

update-resolv-conf: Correctly handle multiple dns search domains,
using the same logic as nameservers. Patch courtesy of Jeremy
Zawodny. (LP: #662847)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/raring/openvpn
This branch contains Public information 
Everyone can see this information.

Subscribers