lp:ubuntu/precise/netatalk

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/precise/netatalk
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

21. By Jonas Smedegaard <email address hidden> on 2011-11-30

* New upstream release.
  + Closes: bug#637025.
  + Fixes FTBFS on GNU/kFreeBSD.
    Closes: bug#630349. Thanks to Petr Salinger.
* Fix typo in comment.
* Update patches:
  + Drop patch 213 (CVE-2008-5718): fixed upstream since 2.0.5.
  + Drop patches 115 and 214 (default → etc/default): fixed upstream
    since 2.2.1.
  + Unfuzz patch 114.
  + Add patch cherry-picked from upstream git, to fix EA header
    related file move/delete errors.
    Closes: bug#648792. Thanks to Tim Miller Dyck.
* Update copyright file: Add/extend a few files sections.
* Update package relations:
  + Tighten build-dependency on cdbs slightly.
  + Relax build-depend unversioned on debhelper and devscripts (needed
    versions satisfied even in oldstable).

20. By Jonas Smedegaard <email address hidden> on 2011-06-05

* New upstream release.
  + Fixes "Internal Error" after ad_open on sparc.
    Closes: bug#606005. Thanks to Alfredo Sola.
* Adjust references to unofficial packages in README.Debian.
* Use dversionmangle (not uversionmangle) in watch file. Fix add
  leading dash (-) to upstream version in mangling.
* Update patches:
  + Drop patches 107 and 294 (Zeroconf support): Implemented
    (differently) upstream now.
  + Drop patches 109 and 112 (avoid broken XFS linkage) obsolete.
  + Drop patch 200 (hostname resolving): adopted upstream.
  + Refresh patch 205.
* Rewrite copyright file using draft 174 of DEP-5 format.
* Build-depend on and recommend unversioned (i.e. default) BerkeleyDB
  packages.
  Closes: bug#621413. Thanks to Ondřej Surý.
  Simplify suggestions on older versioned BerkeleyDB packages.
* Stop installing some documentation dropped upstream, and let CDBS
  automagically handle some of the remains.
* Update control file:
  + Bump policy compliance to standards-version 3.9.2.
  + Shorten Vcs-* URLs.
* Add patches 115 and (for automade file) 214 to avoid installing
  unneeded /default dir.
  Closes: bug#628119. Thanks to Russell Muetzelfeldt and Luk Claes.
* Don't ship .la files. Closes: bug#621849. Thanks to Andreas Metzler
  and Luk Claes.
* Stop renaming afile and achfile, dropped upstream.
* Explicitly enable DDP (AppleTalk), now disabled by default.
* Enable Zeroconf, should be stable now.
* Simplify package relations:
  + Drop (build-)dependency fallback unneeded even for oldstable.

19. By Jonas Smedegaard <email address hidden> on 2010-11-28

* New upstream release.
* Add NEWS entry on BerkeleyDB bump to 4.8 and databases now auto-
  upgrading (replacing older testing-only entry bumping to 4.7).
  Rephrase README.Debian to mention auto-upgrading.
* Bump standards compliance to standards-version 3.9.0.
* Unfuzz patch 114.
* Update copyright file:
  + Fix document a few missed copyright holders (no new licenses).
  + Split comments in License fields into separate License-Comments
    fields.
* Ease building with git-buildpackage: Git-ignore quilt .pc dir, and
  add source local-options.

18. By Jonas Smedegaard <email address hidden> on 2010-06-23

Fix enable DEB_BUILD_HARDENING.

17. By Jonas Smedegaard <email address hidden> on 2010-06-23

* New upstream release.
* Refresh patch 205.
* Tighten reinstall-initscript-quirk: upstream no longer double-
  expands DESTDIR.

16. By Jonas Smedegaard <email address hidden> on 2010-05-15

Drop patch 212 (disable CNID metad by default): the CNID scheme used
by default since Netatalk 2.1, dbd, requires metad enabled.
Closes: bug#581773, thanks to Søren Grønning.

15. By Jonas Smedegaard <email address hidden> on 2010-05-01

* New upstream release.
* Update patches:
  + Drop patches 001, 002, 003, 101, 102, 103, 104, 105, 106, 113,
    206, 210, 214, and disabled patches 291, 292, 293: Merged upstream
    or no longer applies.
  + Refresh remaining (enabled) patches 109, 200, 205, 212, 213, with
    shortening quilt options --no-timestamps --no-index -pab.
  + Disable patch 109: XFS quota support apparently no longer broken.
* Use only official CDBS (drop local snippets): All improvements now
  adopted upstream.
* Use source format 3.0 (quilt), and stop including patchsys-quilt.mk.
* Refer to FSF website (not postal address) in rules file.
* Bump copyright years in header of in rules file.
* Drop locally implemented DEB_MAINTAINER_MODE in rules file: Now
  adopted upstream.
* Rewrite copyright file using draft DEP5 rev. 135. Adds new owners
  and licenses, and some files lacking proper licensing are revealed.
* Install docs README.AppleTalk (not README.platforms, its old name)
  and README.ids.
* Simplify rules file to no longer regenerate autotools: no patches
  affect upstream-shipped automade files.
* Bump standards compliance to standards-version 3.8.4.
* Add workaround for upstream braindead double expanded DESTDIR.
* Tighten build-dependency on cdbs.
* Stop build-depending on libtool, automake1.11 or autoconf.

14. By Jonas Smedegaard <email address hidden> on 2010-01-23

* Fix replace/drop bogus and/or obsolete configure options:
  + Use --without-ssl-dir/--with-ssl-dir (not --with-openssl-dir/
    --without-openssl-dir). Closes: bug#565969, thanks to Fabian
    Greffrath.
  + Use --enable-tcp-wrappers (not --with-tcp-wrappers).
  + Use --disable-srvloc (not --disable-slp).
  + Drop --disable-logger (obsolete since 2.0.1).
  + Drop --with-mangling (apparently obsolete since 2.0 alpha 1).
  + Drop --with-nls-dir and --without-xfs (apparently obsolete).
* Autoreconfigure during build (since upstream does not enable
  maintainer-mode). Disable autotools-related patches. Build-depend on
  libtool, automake1.11 and autoconf. Closes: bug#559060, thanks to
  Cyril Brulebois and others.
* Add safety-check to fail build if accidentally linked against
  libssl. Thanks to Fabian Greffrath (see bug#565969).
* Disable atalkd by default, to not require supported network active
  at daemon start time. Closes: bug#565568, thanks to Kurt Roeckx.
  Add NEWS entry about the change.
* Build-depend on and enable hardening-includes.
* Fix adjust "See also" of manpages referring to afile or achfile.
* Set urgency=medium as earlier lack of explicit disabling openssl
  caused the package to violate licensing for some architectures, also
  affecting testing.

13. By Jonas Smedegaard <email address hidden> on 2009-09-09

* Update copyright hints.
* Lower policy compliance to 3.8.0 (uncertain about sysv script
  requirements in 3.8.1).
* Fix order of db upgrade commands in README.Debian. Closes:
  bug#533344, thanks (again) to Itai Seggev.
* Update package-relations.mk: Cleanup unversioned+versioned
  dependency mix. Improve whitespace cleanup. Rewrite and silence
  applying dependencies.
* Fix and improve README.Debian section on recompiling with OpenSSL,
  thanks to Gijs Hillenius and others.

12. By Steve Langasek on 2009-09-10

No-change rebuild against libkrb5-3

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/netatalk
This branch contains Public information 
Everyone can see this information.