lp:ubuntu/precise-security/libvdpau

Created by Ubuntu Package Importer on 2015-09-03 and last modified on 2015-09-03
Get this branch:
bzr branch lp:ubuntu/precise-security/libvdpau
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

11. By Marc Deslauriers on 2015-09-02

* SECURITY UPDATE: privilege escalation when used in setuid or setgid
  applications
  - debian/patches/CVE-2015-5xxx.patch: use secure_getenv and protect
    against directory traversal in configure.ac, src/Makefile.am,
    src/util.h, src/vdpau_wrapper.c, trace/vdpau_trace.cpp.
  - CVE-2015-5198
  - CVE-2015-5199
  - CVE-2015-5200

10. By Micah Gersten on 2011-12-06

* Merge from debian testing. Remaining changes:
  - Drop gcc-multilib and ia32-libs-dev from build-dependencies
  - Drop lib32vdpau1 binary package from debian/control
  - Drop lib32vdpau1.{lintian-overriders,install,symbols,postinst} files
  - Comment out 32-ARCHS in debian/rules so multilib stuff isn't run
  - Mark Debian VCS links XS-Debian

9. By Artur Rona on 2010-12-04

* Merge from debian unstable. Remaining changes: (LP: #689778)
  - Disable 32bit libraries on amd64, ia32-libs is in universe.

8. By Reinhard Tartler on 2010-06-26

* disable 32bit libraries on amd64, ia32-libs is in universe, LP: #597736
* update Maintainers field.

7. By Russ Allbery on 2010-06-12

[ Russ Allbery ]
* Also version the Conflicts and Replaces for libvdpau-dev so that the
  nvidia-libvdpau-dev transitional package will work properly.
* Add an explicit license for the Debian packaging files.

[ Andreas Beckmann ]
* Add Depends: libx11-dev to libvdpau-dev because vdpau_x11.h includes
  X11/Xlib.h.
* Tighten the dependency of libvdpau-dev on libvdpau1 to only allow the
  matching binary:Version or binary NMUs thereof.
* Remove dh_make boilerplate code and comments from maintainer scripts.
* Unify symbols control files.

6. By Russ Allbery on 2010-05-22

[ Andreas Beckmann ]
* Build lib32vdpau1 [amd64], so we can replace nvidia-libvdpau-ia32.
  Build rules inspired by lib32z1. (Closes: #572206)
* lib32vdpau1: take over postinst script from nvidia-libvdpau-ia32.
* Add lib{,32}vdpau1.symbols.
* libvdpau-dev: do not ship /usr/lib/vdpau/libvdpau_trace.so, won't be used.
* libvdpau1: cleanup /usr/lib/libvdpau_trace.so left over by some old
  versions of the nvidia-libvdpau* packages.

[ Russ Allbery ]
* Link libvdpau with libX11 since it uses symbols from that library.
* Add myself to Uploaders.
* Convert debian/copyright to the DEP-5 format and add the slightly
  different license used for two of the source files.
* Version the Conflicts and Replaces against nvidia-libvdpau1*.
* Also remove /usr/lib/libvdpau_nvidia.so, left by some old versions of
  the nvidia-libvdpau* packages.

5. By Andres Mejia on 2010-02-25

Enable dri2 feature. Requires x11proto-dri2-dev (>= 2.2) and libxext-dev.

4. By Scott Kitterman on 2010-04-17

Cherry pick texlive related build-depends fixes and move documentation
related build-depends to build-depends-indep to fix FTBFS

3. By Randall Donald <email address hidden> on 2009-12-02

[ Andres Mejia ]
* Have libvdpau1 suggest a vdpau driver package to install, rather than
  depend on one.
  (Closes: #558434)
  (Closes: #558464)
* Remove libvdpau-driver package.
* Move libvdpau to main.

2. By Mario Limonciello on 2009-11-29

* debian/control:
  - Don't depend on the metapackage for libvdpau-driver
  - Fix weak library dependency.
* debian/source
  - Drop for now. Launchpad doesn't support 3.0 format
    yet now, so make this look like a 1.0 package.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/wily/libvdpau
This branch contains Public information 
Everyone can see this information.

Subscribers