lp:ubuntu/precise/libktorrent

Created by James Westby on 2011-10-13 and last modified on 2011-12-06
Get this branch:
bzr branch lp:ubuntu/precise/libktorrent
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

11. By Modestas Vainius <email address hidden> on 2011-12-06

* New upstream release.
* Bump debhelper compat level to 9 and require debhelper 8.9.0 in order to
  gain support for transparent dpkg-buildflags handling in dh/dh_auto_*.
* Update symbol file (for 1.1.2/ia64, 1.1.2/sparc), fixes FTBFSes.
* Update symbol file for 1.1.3/amd64, source changes.

10. By Modestas Vainius <email address hidden> on 2011-08-18

* New upstream release.
* Update symbol file.

9. By Modestas Vainius <email address hidden> on 2011-05-26

Release to unstable.

8. By Modestas Vainius <email address hidden> on 2011-02-01

Release to unstable.

7. By Alessandro Ghersi on 2010-10-23

* New upstream release
  - Build against kdelibs5-dev (>= 4:4.5.2a-0ubuntu2)
  - Build against libboost1.42-dev

6. By Alessandro Ghersi on 2010-09-03

New upstream bugfix release

5. By Modestas Vainius <email address hidden> on 2010-07-08

* New upstream release.
* Rename library package to libktorrent2, SONAME has been bumped:
  - rename references in debian/control;
  - rename install and symbol files;
  - bump minver of all symbols to 1.0.2 in the symbol file;
  - change package name and soname in debian/libktorrent2.symbols;
  - change file path in debian/libktorrent2.install.
* Enable parallel support, pass --parallel to dh.
* Update symbol file for 1.0.2 release.
* Bump Standards-Version to 3.9.0: no changes needed.

4. By Modestas Vainius <email address hidden> on 2010-06-15

Set versions of the UTPServer class symbols to 1.0.1.

3. By Modestas Vainius <email address hidden> on 2010-06-15

* New upstream release.
* Drop general_disable_ipv6_only.diff patch, merged upstream.
* Update libktorrent1.symbols for 1.0.1.
* Add "Build-Depends-Package" field to libktorrent1.symbols.

2. By Modestas Vainius <email address hidden> on 2010-05-28

* New upstream release.
* Explicitly disable IPV6_V6ONLY for tcp/udp server sockets
  (Closes: #581896). The proper solution (2 sockets) will be in the next
  major upstream release (patch general_disable_ipv6_only.diff).
* License files are in upstream tarball now, remove the respective note from
  debian/copyright.
* Add debian/README.source.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/libktorrent
This branch contains Public information 
Everyone can see this information.

Subscribers