Ubuntu

lp:ubuntu/precise/libimobiledevice

Created by Ubuntu Package Importer on 2011-10-13 and last modified on 2012-03-18
Get this branch:
bzr branch lp:ubuntu/precise/libimobiledevice
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

17. By Julien Lavergne on 2012-03-18

[ Robert Hooker ]
* Add 06_git_ios5_handle_error.patch, backport from git commit
  e855f246b3 to allow mounting ios 5 devices. (LP: #877440)

[ Julien Lavergne ]
* debian/control:
 - Remove build-depend on libusb2-dev. Thanks Robert Millan (Closes: #659625)
 - Update Standards-Version to 3.9.3 (no change needed).

16. By Robert Hooker on 2012-03-10

Add 06_git_ios5_handle_error.patch, backport from git commit
e855f246b3 to allow mounting ios 5 devices. (LP: #877440)

15. By Julien Lavergne on 2011-10-25

* debian/patches:
 - 05_remove_gcry_need.patch: Remove check and link to gcrypt
   (Closes: #638417)
 - 00git_ios5_support.patch: Fix "Unhandled lockdown error" for iOS 5.
   (LP: #795475)

14. By Martin Pitt on 2011-10-18

* Merge with Debian unstable. Remaining Ubuntu changes:
  - Add 00git_ios5_support.patch: Fix support for iOS 5. (LP #795475)

13. By Martin Pitt on 2011-10-07

Add 00git_ios5_support.patch: Fix "Unhandled lockdown error" for iOS 5.
(LP: #795475)

12. By Julien Lavergne on 2011-04-30

* New upstream release.
* debian/changelog: Fix typo in previous entry.
* debian/patches:
 - 90_fix_4.3_iOS.patch: Merged upstream.
* debian/libimobiledevice-utils.manpages:
 - Add man page for idevicebackup2.
 - Add man page for idevicedate.
 - Add upstream man pages for ideviceenterrecovery and idevicepair.
* debian/control:
 - Remove Conflitcs of libimobiledevice2 to make it installable with
   libimobiledevice1 (Closes: #620065).
 - Add Conflicts/Replaces also on libimobiledevice0-dbg (LP: #693895)
 - Remove python-support from Build-Depends.
 - Increase required python-all-dev package version to 2.6.6-3~.
 - Remove XB-Python-Version fields.
 - Add X-Python-Version field.
 - Bump Standards-Version to 3.9.2.0 (no change needed).
* debian/copyright:
 - Update copyright years.
* debian/libimobiledevice2.symbols:
 - Update with new symbols.
* debian/rules:
 - Use --with python2.
 - Pass --no-guessing-versions to dh_python2 to build only with default
   python version.
* debian/pycompat:
 - Removed.

11. By Julien Lavergne on 2011-04-10

* debian/control:
 - Add Conlicts / Replaces on libimobiledevice1 and libimobiledevice0, since
   they provide the same fdi file. LP: #753015, Closes: #620065
 - Update Maintainer field, and add me to Uploaders.
 - Update Vcs-*.
 - Remove duplicate section.
* debian/gbp.conf:
 - Add specific gdb.conf.

10. By Julien Lavergne on 2010-12-19

* New upstream development release, API is considered unstable.
* debian/libimobiledevice1*, debian/rules, debian/control:
 - Bump SONAME for libimobiledevice library.
* debian/copyright:
 - Update copyright holders.
* debian/libimobiledevice2.symbols:
 - Update with new symbols.
* debian/ideviceenterrecovery.1:
 - Add new manpage.
* debian/libimobiledevice-utils.manpages:
 - Install the new manpage.

9. By Matthias Klose on 2010-12-08

Rebuild with python 2.7 as the python default.

8. By Matthias Klose on 2010-12-03

Rebuild to add support for python 2.7.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/libimobiledevice
This branch contains Public information 
Everyone can see this information.

Subscribers