lp:ubuntu/precise/kde4libs

Created by James Westby on 2011-10-13 and last modified on 2012-03-30
Get this branch:
bzr branch lp:ubuntu/precise/kde4libs
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

264. By Rohan Garg on 2012-03-30

[ Rohan Garg ]
* New upstream release
  - Update symbols for libkparts4 and libkio5

[ Jonathan Thomas ]
* Add kubuntu_fix_nepomuk_utils_crash.diff cherry-pick from KDE's 4.8
  branch. (LP: #948973)

263. By Jonathan Kolberg on 2012-03-03

* New upstream release
  - Update symbol files

262. By Felix Geyer on 2012-02-25

* Install underLGPL.docbook into kdoctools to fix FTBFS of kde-l10n-ru.
  (LP: #935521)
* Install KDescendantsProxyModel into kdelibs5-dev.

261. By Jonathan Riddell on 2012-01-19

New upstream release

260. By Jonathan Riddell on 2012-01-04

[ Jonathan Riddell ]
* New upstream RC release

[ Felix Geyer ]
* Update symbols files.

259. By Philip Muškovac on 2011-12-23

[ Philip Muškovac ]
* New upstream release candidate
  - update kdelibs5-data.install

[ Felix Geyer ]
* Update symbols files.

258. By Jonathan Riddell on 2011-12-16

* New upstream beta release
* Remove kubuntu_mobile patches, kactivities is split out now and they
  will be out of date, keep
  kubuntu-mobile-07-serviceAvailabilityChanged-bool-signal.diff
  for binary compatibility reasons

257. By Jonathan Riddell on 2011-11-22

* Merge from Debian unstable, remaining changes:
  - no build-dep on libaspell-dev
  - no build-dep on libfam-dev
  - kdelibs5-data: don't install kspell_aspell.desktop
  - kdelibs5-plugins: don't install usr/lib/kde4/kspell_aspell.so
  - kdelibs5-dev: don't install preparetips
  - Pass -DKDESU_USE_SUDO_DEFAULT=true to configure
  - dh_fixperms: exclude /usr/lib/kde4/libexec/fileshareset
  - set export KUBUNTU_DESKTOP_POT=kdelibs
  - don't apply use_dejavu_as_default_font.diff
  - don't apply kconf_update_migrate_from_kde3_icon_theme.diff
    - kdelibs5-plugins.install:
      drop usr/share/kde4/apps/kconf_update/kdeui.upd
      and migrate_from_kde3_icon_theme
  - don't build depend on libglu1-mesa-dev, not needed due to
    kubuntu_no_direct_gl_usage.diff
  - Add kdelibs5-data.links: link from /usr/share/doc/kde4 to kde for
    backwards compatible with old docs location
  - Keep the kdelibs5 transitional package
  - kdelibs5-dev.install: install ksambasharedata.h
  - kdelibs5-plugins: recommend ttf-dejavu-core instead of ttf-dejavu to save
    CD space.
  - Make kdelibs5-plugins depend on katepart for transitional reasons.

256. By Philip Muškovac on 2011-10-28

* New upstream release
  - drop kubuntu_no_kbookmark_write_error.diff, fixed upstream
  - drop kubuntu_nepomuk_unicode.diff, fixed upstream
  - update install and symbol files

255. By Felix Geyer on 2011-10-12

Added kubuntu_nepomuk_unicode.diff to fix nepomuk queries as recommended
by upstream.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/kde4libs
This branch contains Public information 
Everyone can see this information.

Subscribers