Ubuntu

lp:ubuntu/precise/freetype

Created by James Westby on 2011-10-13 and last modified on 2012-04-03
Get this branch:
bzr branch lp:ubuntu/precise/freetype
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

47. By Sebastien Bacher on 2012-04-03

* debian/patches-freetype/revert_scalable_fonts_metric.patch:
  - revert commit "Fix metrics on size request for scalable fonts.",
    it's breaking gtk underlining markups and creating some other
    issues as well (lp: #972223)

46. By Tyler Hicks on 2012-03-23

* SECURITY UPDATE: Denial of service via crafted BDF font (LP: #963283)
  - debian/patches-freetype/CVE-2012-1126.patch: Perform better input
    sanitization when parsing properties. Based on upstream patch.
  - CVE-2012-1126
* SECURITY UPDATE: Denial of service via crafted BDF font
  - debian/patches-freetype/CVE-2012-1127.patch: Perform better input
    sanitization when parsing glyphs. Based on upstream patch.
  - CVE-2012-1127
* SECURITY UPDATE: Denial of service via crafted TrueType font
  - debian/patches-freetype/CVE-2012-1128.patch: Improve loop logic to avoid
    NULL pointer dereference. Based on upstream patch.
  - CVE-2012-1128
* SECURITY UPDATE: Denial of service via crafted Type42 font
  - debian/patches-freetype/CVE-2012-1129.patch: Perform better input
    sanitization when parsing SFNT strings. Based on upstream patch.
  - CVE-2012-1129
* SECURITY UPDATE: Denial of service via crafted PCF font
  - debian/patches-freetype/CVE-2012-1130.patch: Allocate enough memory to
    properly NULL-terminate parsed properties strings. Based on upstream
    patch.
  - CVE-2012-1130
* SECURITY UPDATE: Denial of service via crafted TrueType font
  - debian/patches-freetype/CVE-2012-1131.patch: Use appropriate data type to
    prevent integer truncation on 64 bit systems when rendering fonts. Based
    on upstream patch.
  - CVE-2012-1131
* SECURITY UPDATE: Denial of service via crafted Type1 font
  - debian/patches-freetype/CVE-2012-1132.patch: Ensure strings are of
    appropriate length when loading Type1 fonts. Based on upstream patch.
  - CVE-2012-1132
* SECURITY UPDATE: Denial of service and arbitrary code execution via
  crafted BDF font
  - debian/patches-freetype/CVE-2012-1133.patch: Limit range of negative
    glyph encoding values to prevent invalid array indexes. Based on
    upstream patch.
  - CVE-2012-1133
* SECURITY UPDATE: Denial of service and arbitrary code execution via
  crafted Type1 font
  - debian/patches-freetype/CVE-2012-1134.patch: Enforce a minimum Type1
    private dictionary size to prevent writing past array bounds. Based on
    upstream patch.
  - CVE-2012-1134
* SECURITY UPDATE: Denial of service via crafted TrueType font
  - debian/patches-freetype/CVE-2012-1135.patch: Perform proper bounds
    checks when interpreting TrueType bytecode. Based on upstream patch.
  - CVE-2012-1135
* SECURITY UPDATE: Denial of service and arbitrary code execution via
  crafted BDF font
  - debian/patches-freetype/CVE-2012-1136.patch: Ensure encoding field is
    defined when parsing glyphs. Based on upstream patch.
  - CVE-2012-1136
* SECURITY UPDATE: Denial of service via crafted BDF font
  - debian/patches-freetype/CVE-2012-1137.patch: Allocate sufficient number
    of array elements to prevent reading past array bounds. Based on
    upstream patch.
  - CVE-2012-1137
* SECURITY UPDATE: Denial of service via crafted TrueType font
  - debian/patches-freetype/CVE-2012-1138.patch: Correct typo resulting in
    invalid read from wrong memory location. Based on upstream patch.
  - CVE-2012-1138
* SECURITY UPDATE: Denial of service via crafted BDF font
  - debian/patches-freetype/CVE-2012-1139.patch: Check array index values to
    prevent reading invalid memory. Based on upstream patch.
  - CVE-2012-1139
* SECURITY UPDATE: Denial of service via crafted PostScript font
  - debian/patches-freetype/CVE-2012-1140.patch: Fix off-by-one error in
    boundary checks. Based on upstream patch.
  - CVE-2012-1140
* SECURITY UPDATE: Denial of service via crafted BDF font
  - debian/patches-freetype/CVE-2012-1141.patch: Initialize field elements
    to prevent invalid read. Based on upstream patch.
  - CVE-2012-1141
* SECURITY UPDATE: Denial of service via crafted Windows FNT/FON font
  - debian/patches-freetype/CVE-2012-1142.patch: Perform input sanitization
    on first and last character code fields. Based on upstream patch.
  - CVE-2012-1142
* SECURITY UPDATE: Denial of service via crafted font
  - debian/patches-freetype/CVE-2012-1143.patch: Protect against divide by
    zero when dealing with 32 bit types. Based on upstream patch.
  - CVE-2012-1143
* SECURITY UPDATE: Denial of service and arbitrary code execution via
  crafted TrueType font
  - debian/patches-freetype/CVE-2012-1144.patch: Perform input sanitization
    on the first glyph outline point value. Based on upstream patch.
  - CVE-2012-1144

45. By Steve Langasek on 2011-11-17

* New upstream release
  - upstream fix for CVE-2011-3439. Closes: #649122.
  - adjust libfreetype6.symbols for a newly-exported function.

44. By Steve Langasek on 2011-10-24

* Use dpkg-buildflags through debhelper.
* Don't set -Werror in CFLAGS on alpha or m68k, to work around a compiler
  bug. Closes: #646334.

43. By Steve Langasek on 2011-10-22

* New upstream release
  - upstream fix for CVE-2011-3256. Closes: #646120.
  - drop debian/patches-freetype/0001-Fix-Savannah-bug-33992.patch,
    included upstream.
* Pass --without-bzip2 to configure, to avoid unwanted dependency on
  libbz2. Closes: #639638.
* Standards-Version 3.9.2.

42. By Steve Langasek on 2011-08-20

debian/patches-freetype/0001-Fix-Savannah-bug-33992.patch: [PATCH]
Fix Savannah bug #33992. Thanks to David Bevan
<email address hidden>. Closes: #638348.

41. By Marc Deslauriers on 2011-08-08

* SECURITY UPDATE: arbitrary code execution via crafted Type 1 font
  - debian/patches-freetype/CVE-2011-0226.patch: check for proper
    signedness in src/psaux/t1decode.c.
  - CVE-2011-0226
* debian/rules: fix FTBFS with gcc 4.6 by adding
  -Wno-unused-but-set-variable to CFLAGS to downgrade it to a warning.

40. By Steve Langasek on 2011-06-22

* Build for multiarch, using debhelper compat 9.
* Add Pre-Depends: ${misc:Pre-Depends} to pick up multiarch-support
  dependency.

39. By Steve Langasek on 2011-03-22

No-change rebuild against fixed pkgbinarymangler, to get correct
multiarch-safe changelogs

38. By Steve Langasek on 2011-03-18

releasing version 2.4.4-1ubuntu1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/freetype
This branch contains Public information 
Everyone can see this information.

Subscribers