Created by Ubuntu Package Importer on 2012-05-05 and last modified on 2015-08-26
Get this branch:
bzr branch lp:ubuntu/precise-updates/enigmail
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Ubuntu branches
Review team:
Ubuntu Development Team

Recent revisions

48. By Chris Coulson on 2015-08-26

* New upstream release v1.8.2 to support Thunderbird 38
  - Fixes LP: #1489103 - Per-account settings missing after Thunderbird

* Depend on gnupg2 instead of gnupg. Whilst this enigmail version still
  works with gnupg 1.4.*, it pops up an alert warning that it will be the
  last version to do so
  - update debian/control

47. By Marc Deslauriers on 2014-11-14

* SECURITY UPDATE: wrong encryption when only BCC is used
  - New upstream release v1.7.2
  - CVE-2014-5369

46. By Chris Coulson on 2014-01-30

* New upstream release v1.7 to support Thunderbird 31

* No longer requires a Mozilla build system, so we use the upstream
  tarball directly now
  - update debian/rules
  - drop libgtk2.0-dev, libidl-dev, libdbus-glib-1-dev, libnotify-dev,
    libasound2-dev, libxt-dev, autoconf2.13 and mesa-common-dev
    build-depends, as these were only there because we were using a hacked
    Mozilla build system
* Update to source format 3.0
* Drop thunderbird-dev build-depend - the only binary code in enigmail now
  uses ctypes, so we don't need the SDK
* Drop debian/patches/no_libxpcom.patch - it doesn't build a binary component
* Drop debian/patches/use_sdk.patch - there's no dependency on the
  Thunderbird SDK now

45. By Chris Coulson on 2013-09-13

* New upstream release v1.5.2 for Thunderbird 24

* Build enigmail using a stripped down Thunderbird 17 build system, as it's
  now quite difficult to build the way we were doing previously, with the
  latest Firefox build system
* Add debian/patches/no_libxpcom.patch - Don't link against libxpcom, as it
  doesn't exist anymore (but exists in the build system)
* Add debian/patches/use_sdk.patch - Use the SDK version of xpt.py and
* Drop debian/patches/ipc-pipe_rename.diff (not needed anymore)
* Drop debian/patches/makefile_depth.diff (not needed anymore)

44. By Chris Coulson on 2012-11-12

* New upstream release v1.4.6
  - see LP: #1080212 for USN information
* Drop unneeded patches
  - remove debian/patches/correct-version-number.diff
  - remove debian/patches/dont_register_cids_multiple_times.diff
  - update debian/patches/series
* Support building in an objdir
  - update debian/rules

43. By Chris Coulson on 2012-09-26

* New upstream release v1.4.5 to support Thunderbird 16
  - LP: #1062587

* Add patch to set the correct version number. The version was not changed
  from 1.5a1pre to 1.4.5 when the tarball was built from rev 24e938
  - add debian/patches/correct-version-number.diff
  - update debian/patches/series

42. By Chris Coulson on 2012-08-20

* New upstream release v1.4.4 to support Thunderbird 15
  - LP: #1042165

41. By Chris Coulson on 2012-07-11

* New upstream release v1.4.3

* Refresh patches
  - update debian/patches/makefile_depth.diff
  - update debian/patches/ipc-pipe_rename.diff
  - update debian/patches/dont_register_cids_multiple_times.diff

40. By Chris Coulson on 2012-05-28

* New upstream release v1.4.2
  - LP: #1007556

39. By Chris Coulson on 2012-04-18

* New upstream release v1.4.1
  - LP: #987305
* Fix LP: #968122 - Localization messed up

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
This branch contains Public information 
Everyone can see this information.