Merge lp:~ubuntu-branches/ubuntu/precise/eiciel/precise-201111301445 into lp:ubuntu/precise/eiciel

Proposed by Ubuntu Package Importer
Status: Rejected
Rejected by: James Westby
Proposed branch: lp:~ubuntu-branches/ubuntu/precise/eiciel/precise-201111301445
Merge into: lp:ubuntu/precise/eiciel
Diff against target: 0 lines
To merge this branch: bzr merge lp:~ubuntu-branches/ubuntu/precise/eiciel/precise-201111301445
Reviewer Review Type Date Requested Status
Ubuntu branches Pending
Review via email: mp+83955@code.launchpad.net

Description of the change

The package importer has detected a possible inconsistency between the package history in the archive and the history in bzr. As the archive is authoritative the importer has made lp:ubuntu/precise/eiciel reflect what is in the archive and the old bzr branch has been pushed to lp:~ubuntu-branches/ubuntu/precise/eiciel/precise-201111301445. This merge proposal was created so that an Ubuntu developer can review the situations and perform a merge/upload if necessary. There are three typical cases where this can happen.
  1. Where someone pushes a change to bzr and someone else uploads the package without that change. This is the reason that this check is done by the importer. If this appears to be the case then a merge/upload should be done if the changes that were in bzr are still desirable.
  2. The importer incorrectly detected the above situation when someone made a change in bzr and then uploaded it.
  3. The importer incorrectly detected the above situation when someone just uploaded a package and didn't touch bzr.

If this case doesn't appear to be the first situation then set the status of the merge proposal to "Rejected" and help avoid the problem in future by filing a bug at https://bugs.launchpad.net/udd linking to this merge proposal.

(this is an automatically generated message)

To post a comment you must log in.

Unmerged revisions

24. By Michael Biebl on 2011-07-11

* Build for GNOME 3
  - Drop Build-Depends on libgnome2-dev.
  - Bump Build-Depends on libnautilus-extension-dev to (>= 3.0.0).
  - Replace Build-Depends on libgtkmm-2.4-dev with libgtkmm-3.0-dev.
  - Update --with-gnome-version configure flag in debian/rules.

23. By Michael Biebl on 2011-07-11

* New upstream release.
* Switch from cdbs to dh
  - Drop Build-Depends on cdbs.
  - Bump Build-Depends on debhelper for override targets.
  - Convert debian/rules to dh.
  - Add debian/eiciel.docs.
* Bump Standards-Version to 3.9.2. No further changes.
* Bump debhelper compatibility level to 8 and update build dependency
  accordingly.
* debian/rules: Build for GNOME 2.
* debian/watch: Update download URL.

22. By Michael Biebl on 2010-06-24

* New upstream release.
* debian/patches/01-fix-gettext-translations.patch
  - Removed, fixed upstream.
* debian/patches/02-de-po.patch
  - Removed, merged upstream.
* debian/gbp.conf
  - Use bzip2 compression so we no longer need to repack the upstream
    tarball.
* debian/rules
  - An up-to-date German translation is available from the upstream tarball
    so remove the rules to rebuild it.

21. By Michael Biebl on 2010-06-04

* New upstream release.
* debian/patches/02-gio.patch
  - Removed, merged upstream.
* debian/patches/03-no-libgnomeui.patch
  - Removed, merged upstream.
* debian/patches/01-fix-gettext-translations.patch
  - Fix gettext translations by using dgettext and specifying the correct
    domainname.
* debian/patches/02-de-po.patch
  - Update and complete German translation.
* debian/rules
  - Remove de.gmo on clean and rebuild it on build.

20. By Michael Biebl on 2010-05-28

* debian/control
  - Build-Depend on autopoint instead of cvs. Closes: #572466
  - Bump Standards-Version to 3.8.4. No further changes.
  - Drop Build-Depends on libgnomevfs2-dev.
  - Drop Build-Depends on libgnomeui-dev.
  - Add Build-Depends on dh-autoreconf.
* Switch to source fromat 3.0 (quilt)
  - Add debian/source/format.
  - Drop quilt from Build-Depends.
  - Remove /usr/share/cdbs/1/rules/patchsys-quilt.mk from debian/rules.
* debian/patches/01-makefile_am.patch
  - Drop this patch. Specifying all libraries manually is too cumbersome and
    error prone. Removing this patch also fixes the build failures with
    binutils-gold. Closes: #554321
* Use dh-autoreconf to update the build system instead of doing it manually.
* debian/patches/03-no-libgnomeui.patch
  - Remove dependency on libgnomeui. For showing the application
    documentation, libgnome is sufficient.

19. By Michael Biebl on 2009-04-08

* debian/control
  - Wrap Build-Depends.
  - Bump Standards-Version to 3.8.1. No further changes.
  - Bump Build-Depends on debhelper to (>= 7).
* debian/compat
  - Bump debhelper compat level to 7.

18. By James Westby on 2008-11-22

Add --install to libtoolize call in debian/rules so that all necessary
files get installed.

17. By Michael Biebl on 2008-10-25

* debian/control
  - Bump Standards-Version to 3.8.0, no further changes.
  - Add Vcs-* fields.
* Switch patch system to quilt.

16. By Michael Biebl on 2008-04-18

* New upstream release.
* debian/patches/02-gcc43_includes.patch
  - Removed, merged upstream.

15. By Cesare Tirabassi on 2008-04-18

debian/rules:
change also hardcoded nautilus extension paths in the binary-install target

Preview Diff

Empty

Subscribers

People subscribed via source and target branches

to all changes: