lp:ubuntu/oneiric/xiphos

Created by James Westby on 2011-04-28 and last modified on 2011-07-08
Get this branch:
bzr branch lp:ubuntu/oneiric/xiphos
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

19. By Dimitri John Ledkov on 2011-06-25

[ Dmitrijs Ledkovs <email address hidden> ]
* Drop xulrunner, use gtkhtml instead. (Closes: #631049) (LP: #756201)
* Drop quilt dependency (daily ppa converts 3.0 quilt format to 3.0 native)
* Bump policy to 3.9.2, no changes required.

18. By Chris Coulson on 2011-04-15

* Fix LP: #761715 - xiphos will stop working after the Firefox 4.0.1
  release. We just hard-code the min/max Gecko versions for now rather
  than trying to figure them out dynamically at build time. The existing
  method of doing that doesn't seem to handle all combinations of Gecko
  versions and also currently makes it FTBFS
  - update debian/patches/xul-2.0.patch

17. By Dimitri John Ledkov on 2010-11-29

[ Dmitrijs Ledkovs <<email address hidden> ]
* Release to unstable
* Simplify and reduce logic in debian/rules.
* Drop gnomesword package now that squeeze is released
* Add dependency (renamed) libgtkhtml-editor-3.14-dev (Closes: #613971)

16. By Dimitri John Ledkov on 2010-11-25

[ Jonathan Marsden ]
* New upstream release 3.1.4
* Removed debian/patch/* since the one patch was included upstream.
* Bumped Standards-Version to 3.9.1 (no changes required).
* debian/README.Debian: Corrected spelling and reworded for clarity.
* debian/control: Add Jonathan Marsden back into Uploaders.

[ Dmitrijs Ledkovs ]
* Added local options dpkg-source to unapply patches and fail on
  upstream source changes (ignoring false positives).
* Added bzr-builddeb hook to generate source-format before build. If you
  are not using bzr-builddeb, you must run "./debian/rules clean" before
  building.
* patches/xul-2.0.patch: bump UPPER_RANGE to allow running against xul20.

15. By Dimitri John Ledkov on 2010-05-24

Fix FTBFS on hppa (Closes: #582904)

14. By Dimitri John Ledkov on 2010-04-03

* Fixing Intrepid->Karmic builds. It was a perl bug.
* Added debug package
* Manually adding xulrunner dependency when dh_xulrunner is not available.
* Lzma compressed debs when version has ~ (e.g. ppa)
* Source format 3.0 (quilt) official, 1.0 ppas
* Keeping XDG desktop file & icon in arch package to appear in appinstall-data
* Cleaned up build-dependencies
* Rebuild to pick up new gtkhtml dependency (Closes: #582169)

13. By Dimitri John Ledkov on 2010-03-22

* New upstream release:
  + Bugfix only
  + Compatible with xulrunner 1.9.2
  + Update translations

* Revert changes introduced in 3.1.2-1ubuntu1. Thank you Chris Coulson
  for temporary fix.
* debian/xiphos.1 - spelling mistake
* waf is now default buildsystem
* help is now licensed under GPL
* Bumped standards version no changes required
* Changed email to @ubuntu.com

12. By Chris Coulson on 2010-03-22

* Port to xulrunner 1.9.2:
  - drop debian/patches/xul192-workaround.patch
  - don't explicitly depend on xulrunner-1.9.1
    + update debian/control
  - call dh_xulrunner to automatically populate the binary depends
    + update debian/rules
  - Ignore open_uri events from GtkMozEmbed if the URI matches the
    base_uri passed to gtk_moz_embed_open_stream. Since xulrunner 1.9.2,
    calling gtk_moz_embed_open_stream triggers an open_uri event, but we
    don't really want to handle these
    + add debian/patches/gtkmozembed-1.9.2-port.patch
    + update debian/patches/series

11. By Chris Coulson on 2010-03-12

* debian/patches/xul192-workaround.patch:
  - Ensure that we don't load the 1.9.2 GRE if it is installed, as
    1.9.2 makes xiphos unusable at the moment. This is a temporary
    measure until the new xulrunner behaviour is understood
* debian/control:
  - Explicitly depend xulrunner-1.9.1
* debian/rules:
  - Don't call dh_xulrunner to automatically populate the binary depends.
    This is known to be broken in xulrunner-1.9.1 (it adds an incorrectly
    versioned dependency). We add it manually instead

10. By Micah Gersten on 2010-02-28

No source change rebuild against xulrunner-1.9.2 (LP: #536877)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/xiphos
This branch contains Public information 
Everyone can see this information.

Subscribers