lp:ubuntu/oneiric/tuxguitar

Created by James Westby on 2011-04-28 and last modified on 2011-08-15
Get this branch:
bzr branch lp:ubuntu/oneiric/tuxguitar
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

20. By Micah Gersten on 2011-08-15

* Add back changes from 1.2-8ubuntu2 that were accidentally dropped
  - add debian/patches/04-no-mozilla.patch
  - drop xulrunner-1.9.1 from Depends
* This also finally fixes the installation issue mentioned in
  (LP: #811096)

19. By Tony Mancill on 2011-07-26

* Update debian/control
  - build/depend on swt-gtk-3 (3.7) instead of 3.6.
  - replace build-dep on gcj with gcj-jdk
  - replace dependency on libswt-mozilla-gtk-3-jni
    with libswt-webkit-gtk-3-jni
* Update debian/patches/01-tuxguitar-rzr.patch for classpath changes

18. By Alessio Treglia on 2011-08-05

No-change rebuild for fluidsynth (LP: #821346)

17. By Paolo Sammicheli on 2011-07-03

* Merge from debian unstable. (LP: #797887) Remaining changes:
  - add debian/patches/04-no-mozilla.patch
  - drop xulrunner-1.9.1 from Depends

16. By Chris Coulson on 2011-03-23

* Rebuild against new swt-gtk and replace mozilla depends with webkit
  - FFe LP: #740815
  - update debian/control
* Drop unneeded patches
  - remove debian/patches/xulrunner-1.9.2.patch
  - remove debian/patches/03-CVE-2010-3385.patch
  - update debian/patches/series
* Drop the LD_LIBRARY_PATH kludge from the start script
  - add debian/patches/03-no-mozilla.patch
  - update debian/patches/series

15. By Micah Gersten on 2010-10-14

* SECURITY UPDATE: insecure library loading (LP: #660923)
  - debian/patches/03-CVE-2010-3385.patch: Use shell expansion when setting
    LD_LIBRARY_PATH. Patch from Debian version 1.2-7
  - CVE-2010-3385
* Merge from debian unstable. Remaining changes:
  - add debian/patches/xulrunner-1.9.2.patch
    + misc/tuxguitar.sh: update to use xulrunner-1.9.2
  - debian/control: Update depends to xulrunner-1.9.2

14. By Micah Gersten on 2010-08-29

* Merge from debian unstable. Remaining changes:
  - add debian/patches/xulrunner-1.9.2.patch
    + misc/tuxguitar.sh: update to use xulrunner-1.9.2
  - debian/control: Update depends to xulrunner-1.9.2

13. By Micah Gersten on 2010-07-21

No change rebuild to pick up new j-a-c-k shlibs

12. By Micah Gersten on 2010-07-10

* Merge from debian unstable. (LP #604171) Remaining changes:
  - misc/tuxguitar.sh: tuxguitar still looks for xulrunner-1.9.1
  - debian/control: Update depends to xulrunner-1.9.2

11. By Luke Faraone on 2010-05-28

* Remerge accidentally omitted changes from previous sync:
  - misc/tuxguitar.sh: tuxguitar still looks for xulrunner-1.9.1 (LP: #544830)
  - debian/control: Update depends to xulrunner-1.9.2 (LP: #536796)
* Update maintainer.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/tuxguitar
This branch contains Public information 
Everyone can see this information.

Subscribers