lp:ubuntu/oneiric/nvidia-graphics-drivers-96

Created by James Westby on 2011-04-28 and last modified on 2011-10-10
Get this branch:
bzr branch lp:ubuntu/oneiric/nvidia-graphics-drivers-96
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

46. By Alberto Milone on 2011-10-10

Re-enable grub fb and drop the initramfs hook in favour of
"alias nouveau/lbm_nouveau off" (LP: #864149).

45. By Alberto Milone on 2011-09-30

* debian/rules:
  - Make sure that the module alias is always correct and
    uses underscores instead of hyphens (LP: #855396).
  - Make the grub-gfxpayload file a template and blacklist
    all Nvidia cards so that Grub doesn't set a framebuffer
    which prevents recovery mode from working (LP: #854967).

44. By Alberto Milone on 2011-09-07

* debian/rules:
  - Remove trailing spaces.
  - Blacklist the updates flavours in modprobe.conf.
  - Add an initramfs hook to make sure that nothings else loads
    open graphics drivers in the initramfs (LP: #839524).

43. By Alberto Milone on 2011-08-30

* debian/nvidia-96.postinst{.in}:
  - Make sure to create and use X.Org's multiarch extra modules
    path (LP: #807209).
  - Share the same name for grub's blacklist file for all
    drivers.
* debian/rules:
  - Fix issues with pbuild.
  - Do not provide the X abi any longer. Depending on the ABI is
    enough.

42. By Alberto Milone on 2011-08-01

Put back in nvidia-2.6.36-ioctl.patch to fix FTBFS.

41. By Alberto Milone on 2011-08-01

* New upstream release:
  - Fixed a bug that caused freezes and crashes when resizing
    windows in KDE 4 with desktop effects enabled using X.Org
    X server version 1.10 or later.
  - Added support for X.Org xserver 1.10 (LP: #741930).
* debian/control.in:
  - Drop transitional packages.
* debian/dkms.conf.in:
  - Prevent DKMS builds with kernels newer than the ones we ship.
* debian/dkms/patches:
  - Drop obsolete patches.
* debian/nvidia-96.postinst.in:
  - Add support for multi-arch (LP: #798049).
  - Remove slave link to nvidia-smi since the binary does not
    exist.
  - Remove any previous gl_conf alternative.
* debian/nvidia-96.README.Debian.in
  - Update the README with the DKMS OBSOLETE_BY option.
* debian/rules:
  - Do not hardcode the X ABI any more.
  - Install an empty ld.so.conf for the fake alternative
  - Remove obsolete instructions from debian/rules
  - Prevent the build from failing when no patches are available.

40. By Alberto Milone on 2011-03-08

Correct typo in debian/control{.in} again, as the correction
was not included in the previous revision (LP: #639955).

39. By Bryce Harrington on 2011-03-07

[ Andrea Carpineti ]
Fix typo in package description Geforce to GeForce
(LP: #639955)

38. By Alberto Milone on 2011-02-28

* debian/control{.in}:
  - Depend on ${xviddriver:Depends}.
* debian/rules:
  - Manually set video ABI compatibility to 8 so that the driver is not
    installable in applications such as Jockey or manually.
  - Correct comment about what the file is based on.

37. By Alberto Milone on 2011-01-07

Remove .patch files that were accidentally uploaded.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/nvidia-graphics-drivers-96
This branch contains Public information 
Everyone can see this information.

Subscribers