lp:ubuntu/oneiric/m2300w

Created by James Westby on 2011-04-28 and last modified on 2011-08-19
Get this branch:
bzr branch lp:ubuntu/oneiric/m2300w
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

16. By Till Kamppeter on 2011-08-19

* debian/rules: Added PPD files for the KONICA MINOLTA versions of the
  magicolor 2300W/2400W (LP: #250583).
* debian/rules, debian/control: Compress PPD files with pyppd.
* debian/rules, debian/control, debian/m2300w.postinst,
  debian/m2300w.ppd-updater: Let automatic update of the PPDs of already
  existing print queues be done by CUPS.

15. By Till Kamppeter on 2011-08-19

debian/control: Versioned build dependency on foomatic-db to assure that
the Ubuntu build server installs the physical package foomatic-db and
not foomatic-db-compressed-ppds which only provides foomatic-db.

14. By Till Kamppeter on 2011-08-01

debian/control: Changed build dependency on foomatic-db-xml back to
foomatic-db and added "Build-Conflicts: foomatic-db-compressed-ppds"
instead to assure that the Foomatic XML database is present during
package build and not only the compressed archive of the Foomatic PPD
files.

13. By Till Kamppeter on 2009-07-28

debian/control: Changed build dependency on foomatic-db to foomatic-db-xml
to assure that the Foomatic XML database is present and not only the
compressed archive of the Foomatic PPD files.

12. By Till Kamppeter on 2009-07-24

debian/patches/20_use_ghostscript_with_nointerpolate.dpatch: Added
"-dNOINTERPOLATE" to the Ghostscript command line. This makes the
page rendering by Ghostscript significantly faster.

11. By Martin Pitt on 2011-01-24

debian/control: Fix build deps: gs → ghostscript.

10. By Alexander Sack on 2010-03-07

rebuild rest of main for armel armv7/thumb2 optimization;
UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2

9. By Till Kamppeter on 2009-09-18

* debian/m2300w.postinst: Fixed "lpstat -r" check for the
  auto update of PPDs of existing queues. "lpstat -r" exits always with
  status 0, we must check the actual output. Call lpstat, lpadmin, and
  cupsctl with "-h /var/run/cups/cups.sock" to avoid querying remote
  servers set up in /etc/cups/client.conf, and asking for passwords.
  Thanks to Martin-Éric Racine for tracking this down and the solution!
  See Debian bug #543468. Use signal names instead of numbers for trap.
  Quiesces a lintian bashism warning.

* debian/control: Added dependency on cups and cups-client, to assure
  that automatic update of the PPDs of existing print queues.

8. By Till Kamppeter on 2009-03-26

* debian/m2300w.postinst: Silenced non-fatal error messages when
  post-install script updates PPDs and there are PPDs not belonging to
  a CUPS queue in /etc/cups/ppd/ (LP: #345866).

* debian/local/apport-hook.py, debian/rules: Added apport hook (LP: #338442).

7. By Till Kamppeter on 2008-02-18

debian/m2300w.postinst: Added automatic updating of the PPD files of the
already existing CUPS queues which use this driver.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/m2300w
This branch contains Public information 
Everyone can see this information.

Subscribers