lp:ubuntu/oneiric/libunity

Created by James Westby on 2011-04-28 and last modified on 2011-09-29
Get this branch:
bzr branch lp:ubuntu/oneiric/libunity
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

23. By Sebastien Bacher on 2011-09-29

Backport r85 to make "SearchFinished signals work again", it's needed
to fix the unity dash activating the wrong entry on enter (lp: #856205)

22. By Didier Roche on 2011-09-27

* New upstream release.
  - doesn't clear models when a scope dies (LP: #859760)
  - Support X-GNOME-Keywords (LP: #828356)
* update debian/libunity6.symbols

21. By Didier Roche on 2011-09-15

* New upstream release:
  - Scope searches blocks the lens (LP: #850816)
  - [dash] Category filters is sorted according to their english names,
    even when another language is used (LP: #838023)
  - No way to get original path of GAppInfo from Unity.AppInfoManager
    (LP: #850817)
* debian/libunity6.symbols:
  - updated symbols

20. By Didier Roche on 2011-09-08

* New upstream release.
  - [dash] Apps lens shows no result by default (LP: #834571)
  - Quicklist can't be correctly hidden (LP: #843425)
  - Python PyGI support broken (LP: #844779)
* debian/control,
  debian/libunity5.symbols => debian/libunity6.symbols,
  debian/libunity5.install => debian/libunity6.install:
  - makes the necessary tweak for ABI/API breakage

19. By Didier Roche on 2011-08-12

* debian/control:
  - conflicts and replaces gir1.2-unity-3.0 as the needed override file
    isn't versionned (no provides: because of the API break)

18. By Didier Roche on 2011-08-11

* debian/control:
  - late bump to unity gir 4.0. So build gir1.2-unity-4.0 bin package

17. By Didier Roche on 2011-08-11

* debian/control:
  - build with valac-0.12

16. By Didier Roche on 2011-08-11

* New upstream release.
* bump soname:
  - rename debian/libunity4* -> debian/libunity5*
  - rename in the control file as well, add a replaces because of the gir file
  - update debian/libunity5.symbols
* debian/control:
  - bump Standards-Version
  - breaks on current unity and unity-2d

15. By Ken VanDine on 2011-06-24

* debian/control
  - Ensure we rebuild against dbusmenu >= 0.4.90

14. By Didier Roche on 2011-04-07

* New upstream release.
  - [FFE] Need API to set urgency from background process (LP: #747677)
  - Launcher - Remove the capability for Launcher icons to be overlaid with
    emblems (LP: #747311)
  - When we press Enter to run the first search result, Unity should wait
    until searching is finished (LP: #749428)
* debian/libunity3.install => debian/libunity4.install
  debian/libunity3.symbols => debian/libunity4.symbols
  debian/control, debian/libunity4.symbols:
  - handle abi break and soname bump
  - replaces libunity3 for the gir file

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/libunity
This branch contains Public information 
Everyone can see this information.

Subscribers