lp:ubuntu/oneiric/jockey

Created by James Westby on 2011-04-28 and last modified on 2011-10-06
Get this branch:
bzr branch lp:ubuntu/oneiric/jockey
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

133. By Jeremy Bicha on 2011-10-06

jockey/oslib.py: Update help link (LP: #866085)

132. By Martin Pitt on 2011-09-29

Only ask for confirmation in check_composite if --confirm has been set.
Thanks to Evan Dandrea! Patch cherrypicked from trunk r740.
(LP: #855042)

131. By Martin Pitt on 2011-09-28

data/handlers/{fglrx,nvidia}.py: Drop custom id() methods. They were a
thinko and cause the driver IDs to come out as e. g.
"xorg:nvidia_173_updates-update". The module name is meant to provide
the "_update" suffix already (just didn't do yet because of LP #855396)

130. By Martin Pitt on 2011-09-21

[ Alberto Milone ]
* data/handlers/fglrx.py: Use the correct name for the module and for the
  package in fglrx.py. (LP: #855396)

[ Martin Pitt ]
* jockey/oslib.py, package_header_modaliases(): Only consider packages for
  the system architecture. This avoids creating non-working default handlers
  for e. g. fglrx:i386 on an amd64 system. (LP: #855175)
* Drop data/handlers/nouveau3d.py, it's installed by default now.
  (LP: #839533)

129. By Alberto Milone on 2011-09-07

* data/handlers/{fglrx,nvidia}.py:
  - Pass the correct kernel module name when dealing with updates flavours
    (LP: #841462).

128. By Martin Pitt on 2011-09-05

jockey/oslib.py: Fix crash if an apt error occurs even before forking the
apt progress backend. (LP: #838276)

127. By Martin Pitt on 2011-09-01

* Merge fix from trunk:
  - detection.py: Fix crash if Driver ID does not have a package field.
    (LP: #837495)

126. By Martin Pitt on 2011-08-30

jockey/ui.py, jockey/backend.py: Use MainLoop from GObject, not from GLib.
Using GLib is broken for pygobject 2.28. This can be reverted once
pygobject gets upgraded to 2.90. (LP: #836599)

125. By Martin Pitt on 2011-08-22

debian/rules: Run debian/testpkgs/clean through sh, as we use V1 source
and can't keep the executable bit there.

124. By Martin Pitt on 2011-08-22

* New upstream bug fix release:
  - oslib.py: Do not encourage to report package installation failure as
    SystemError, it will appear as a backend crash
  - jockey-gtk: Fix message_type argument to Gtk.MessageBox constructor
  - jockey/ui.py: For invalid combinations of LC_MESSAGES and LC_CTYPE, force
    stdout/stderr encoding to UTF-8 instead of C. (LP: #760883)
  - Fix GLib and GObject imports to be compatible with the future pygobject
    3.0. (LP: #829186)
  - jockey/detection.py, _driverid_to_handler(): In the case that there are
    multiple matching custom handlers for a DriverID, also check that their
    "package" attribute matches.
  - tests/run: Also support specifying individual test method names
* Add debian/testpkgs/: Scripts and equivs control files for dummy
  driver packages which are convenient for testing.
* debian/rules: Call debian/testpkgs/clean to ensure that we don't ship
  build stuff there.
* data/handlers/{fglrx,nvidia}.py: Prevent crash if
  get_alternative_by_name() returns nothing.
* jockey/oslib.py, {install,remove}_package(): Capture apt's stdout/err into
  the log file, to get proper error messages when packages fail to install.
  (LP: #552300).
* jockey/oslib.py, install_package(): Avoid raising a SystemError when a
  package fails to install in apt, as this will appear as a crash in Jockey.
  Just point out the error in the log file instead. (LP: #804709)
* tests/oslib.py: Update test cases for above change.
* tests/oslib.py: Fix apt initialization to work with current apt versions.
* data/handlers/{fglrx,nvidia}.py: Also show the -updates variants of the
  drivers, which will be updated to newer upstream versions after the
  Ubuntu release. (UbuntuSpec:desktop-o-xorg-stakeholders-request)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/jockey
This branch contains Public information 
Everyone can see this information.

Subscribers