lp:ubuntu/oneiric/hplip

Created by James Westby on 2011-04-28 and last modified on 2011-09-28
Get this branch:
bzr branch lp:ubuntu/oneiric/hplip
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

178. By Till Kamppeter on 2011-09-27

* debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch:
  Simplified the construction of the title line of the hp-systray applet
  menu, so that the applet-to-indicator converter sni-qt also imports this
  title line (at least the text of it). Thanks to Aurelien Gateau for this
  patch.
* debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch:
  Make the menu of the hp-systray applet appearing when the applet is
  converted to an indicator applet by sni-qt and put into the notification
  area of KDE (LP: #857929).

177. By Till Kamppeter on 2011-09-23

debian/patches/hpfax-bug-function-used-before-importing-log.dpatch:
The hpfax CUPS backend uses its function bug() (which in turnuses log())
before log() gets imported (with base.g). Made use of log() in bug()
optional (LP: #560849).

176. By Till Kamppeter on 2011-09-22

debian/patches/mdns-py-typo.dpatch: Fixed typo in code (LP: #757899).

175. By Till Kamppeter on 2011-09-01

debian/patches/mdns-py-network-printer-search-key-error.dpatch:
In some cases a search of network printers with the hp-setup utility
crashed with a key error (LP: #519430).

174. By Till Kamppeter on 2011-08-21

debian/control, debian/rules: Use new debhelper dh_pyppd to compress the
PPD files.

173. By Till Kamppeter on 2011-08-17

* debian/hpijs.ppd-updater, debian/hplip-cups.ppd-updater,
  debian/hplip.ppd-updater, debian/hpijs-ppds.ppd-updater: Added data files
  to trigger the update of the PPD files of existing print queues by CUPS
  and to tell CUPS which PPD files to use for the update and how to match
  them with the PPDs of the existing queues.
* debian/hplip.postinst: Removed the repeated code for updating the PPD
  files of existing print queues. This code is now centralized in the
  cups package, as a trigger.
* debian/hpijs.postinst, debian/hplip-cups.postinst,
  debian/hpijs-ppds.postinst: Removed the post-install scripts which only
  contain the code for updating the PPDs of existing print queues.
* debian/hpijs.install, debian/hplip-cups.install, debian/hplip.install,
  debian/hpijs-ppds.install, debian/rules: Install the *.ppd-updater
  file of each printer driver/PPD package in the /usr/share/cups/ppd-updaters
  directory.
* debian/control: Removed the dependency on cups-client from the printer
  driver/PPD packages, as we do not call the command line utilities of CUPS
  in the post-install scripts any more. Also removed the dependency on CUPS
  from the hpijs and hpijs-ppds packages.

172. By Steve Langasek on 2011-08-10

releasing version 3.11.7-0ubuntu2

171. By Steve Langasek on 2011-08-10

switch from the deprecated python-support to dh_python2.

170. By Steve Langasek on 2011-08-09

run update-maintainer

169. By Steve Langasek on 2011-08-09

debian/patches/cups-1.5.0-compatibility.dpatch: directly include
cups/ppd.h, for compatibility with cups 1.5.0.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/hplip
This branch contains Public information 
Everyone can see this information.

Subscribers