lp:ubuntu/natty/yelp

Created by James Westby on 2010-10-13 and last modified on 2011-04-12
Get this branch:
bzr branch lp:ubuntu/natty/yelp
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

106. By Robert Ancell on 2011-04-12

* Backport some patches from 3.0.1
* debian/patches/00_build_with_gtk2.patch:
  - Fix up some warnings
* debian/patches/00git_clear_gvariantbuilder.patch:
  - Fix memory leak saving bookmarks
* debian/patches/00git_split_search_string.patch:
  - Improve matching with search string
* debian/patches/00git_use_gsettings.patch:
  - Use GSettings for config

105. By Robert Ancell on 2011-04-05

New upstream release

104. By Steve Langasek on 2011-03-22

debian/rules: use clean-la.mk from gnome-pkg-tools to clean up
dependency_libs fields, per policy 10.2

103. By Robert Ancell on 2011-03-22

New upstream release

102. By Steve Langasek on 2011-03-22

debian/rules: clean the dependency_libs out of libyelp.la at build
time, per Policy 10.2.

101. By Robert Ancell on 2011-03-22

* debian/patches/06_default_uri.patch:
  - Dropped, the documentation has been updated and now provides the default
    URI (LP: #739222)

100. By Robert Ancell on 2011-03-08

* New upstream release
* debian/patches/06_default_uri.patch:
  - Use old default URI

99. By Robert Ancell on 2011-02-25

* New upstream release
  - Brings back searching. (LP: #710901)
* debian/control:
  - Add build-depends on libsqlite3-dev

98. By Martin Pitt on 2011-01-15

[ Robert Ancell ]
* debian/patches/02_man-utf8.patch:
  - Dropped, confirmed as fixed by the latest Yelp

[ Martin Pitt ]
* debian/control.in: Add missing yelp-xsl dependency.

97. By Robert Ancell on 2011-01-11

* New upstream release
* debian/control:
  - Drop build-depends on quilt, libgconf2-dev, gnome-doc-utils,
    libstartup-notification0-dev, libdbus-glib-1-dev, librarian-dev,
    xulrunner-dev
  - Add build-depends on liblzma-dev, libwebkitgtk-dev, yelp-xsl
  - Bump build-depends on libglib2.0-dev, libgtk2.0-dev
* debian/rules:
  - Remove obsolete DEB_AUTO_UPDATE macros
  - Remove obsolete configure flags
  - Build with --with-gtk=2.0
  - Remove xulrunner rules
* debian/patches/00_build_with_gtk2.patch:
  - Build with GTK2
* debian/patches/00_no_am_gnu_gettext.patch:
  - Can't use both AM_GNU_GETTEXT and IT_PROG_INTLTOOL
* debian/patches/04_new_ubuntu_layout.patch:
  - Disabled for now, needs to be fixed
* debian/patches/02_man-utf8.patch:
  - Disabled for now, suspected not needed?
* debian/patches/06_ubuntu_online_url.patch:
  - Dropped, search not implemented in yelp 2.91.10
* debian/patches/08_link_order.patch:
  - Fixed in 07_build_with_dsolink.patch
* debian/patches/09_add_mimetype_to_desktop.patch:
  - Applied upstream
* debian/patches/10_ubuntu_gecko_version.patch:
* debian/patches/11_support_xulrunner_20.patch:
  - Obsolete, not using Gecko anymore

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/yelp
This branch contains Public information 
Everyone can see this information.

Subscribers