Created by Ubuntu Package Importer on 2012-08-22 and last modified on 2012-08-22
Get this branch:
bzr branch lp:ubuntu/natty-updates/rssh
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Ubuntu branches
Review team:
Ubuntu Development Team

Recent revisions

13. By Jamie Strandboge on 2012-08-22

fake sync from Debian

12. By Jamie Strandboge on 2012-08-21

fake sync from Debian

11. By Russ Allbery on 2010-11-10

When allocating the buffer to tell a locked-out user what commands are
supported, add an additional byte for the nul at the end of the
string. (Closes: #601145)

10. By Russ Allbery on 2010-07-06

* If parsing the configuration file fails, abort with an error rather
  than continuing on and applying the defaults, since the defaults may
  be wrong for the current user. Patch from Jon Barber.
* Fix spelling error (seperate for separate) in rssh man page.
* Remove version from openssh-server dependency since it was older than
* Update standards version to 3.9.0 (no changes required).

9. By Russ Allbery on 2010-03-29

* Switch to 3.0 (quilt) source format.
  - Remove build dependency on quilt and debian/rules machinery.
* Remove all of the files touched by autoreconf -i.
* Remove Jesus Climent from uploaders. He hasn't had time to work on
  the package in a while.
* Update standards version to 3.8.4 (no changes required).

8. By Russ Allbery on 2009-07-18

* Update standards version 3.8.2 (no changes required).
* Translation updates:
  - Czech, thanks Martin Šín. (Closes: #533389)
  - Russian, thanks Yuri Kozlov. (Closes: #537062)

7. By Russ Allbery on 2009-04-04

* This package is now maintained using Git and TopGit. A quilt
  patch series is exported from TopGit branches for the final Debian
  package. Update debian/README.source, the Vcs-* control fields, and
  debian/rules accordingly.
* Add support for svnserve (Subversion). This requires a change in the
  format of /etc/rssh.conf to add an additional binary digit to the
  permissions field. /etc/rssh.conf will be automatically updated as
  part of the package upgrade using /usr/share/rssh/conf_convert. Patch
  from Davide Scola. (Closes: #284756)
* In mkchroot, also install /dev/zero in the chroot. Noted in an
  updated patch from Ross Davis sent to the rssh-discuss list.
* Remove postrm script that removed rssh from /etc/shells. We do that
  in postinst on upgrade and have for some time, so this maintainer
  script was unnecessary.
* Convert to the proposed new copyright format.
* Swap Maintainer and Uploaders, making me the primary maintainer. I've
  done all of the recent uploads.
* Update debhelper compatibility level to V7.
  - Use rule minimization with overrides.
  - Move install, examples, and manpage lists into separate files.
  - Add --enable-static if "static" is in DEB_CONFIGURE_OPTIONS rather
    than requiring the variable be set to exactly --enable-static.
  - Remove unnecessary debian/dirs.
* Update standards version to 3.8.1 (no changes required).
* Translation updates:
  - Spanish, thanks Francisco Javier Cuadrado. (Closes: #509356)

6. By Russ Allbery on 2008-07-13

* The upstream mkchroot script uses echo -e, so make it a /bin/bash
  script, which is less invasive than rewriting all of the echo
  statements to printf. Thanks, Raphael Geissert. (Closes: #489653)
* Update standards version to 3.8.0.
  - Add a README.source file pointing to the quilt documentation.

5. By Russ Allbery on 2007-02-15

* Translation updates:
  - Portuguese, thanks Miguel Figueiredo. (Closes: #410869)

4. By Jesus Climent on 2005-01-19

* New upstream release
* Security fix: CAN-2004-1161. Closes: #284207.
* Translations update:
  - de.po: Jens Nachtigall (Closes: #276697)
  - ja.po: Hideki Yamane (Closes: #272899)
  - cs.po: Miroslav Kure (Closes: #287300)
  - it.po: Luca Monducci (Closes: #288828)
* Urgency set to high due to the security fix and to get it into Sarge.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
This branch contains Public information 
Everyone can see this information.