lp:ubuntu/natty-updates/python-crypto

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/natty-updates/python-crypto
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

15. By Marc Deslauriers

* SECURITY UPDATE: incorrect ElGamal key generation
  - debian/patches/CVE-2012-2417.patch: generate safe prime numbers in
    lib/Crypto/PublicKey/ElGamal.py, backport getRandomRange() to
    lib/Crypto/Util/number.py.
  - CVE-2012-2417

14. By Stefano Rivera

* Merge from Debian unstable (LP: #662883). Remaining changes:
  - Install the -dbg build using --install-layout=deb.
* Droppped changes, superseded in Debian:
  - The md5 module is deprecated in Python 2.6, use hashlib when possible.
  - Explicitly use python2.5 to build the docs; the old doc tools are not
    included in python2.6 anymore.

13. By Matthias Klose

Build-depend on python-old-doctools instead of python2.5-dev.

12. By Muharem Hrnjadovic

* Merge from debian unstable (LP: #388002), remaining changes:
  - Install the -dbg build using --install-layout=deb.
  - The md5 module is deprecated in Python 2.6, use hashlib when possible.
  - Explicitly use python2.5 to build the docs; the old doc tools are not
    included in python2.6 anymore.

11. By Colin Watson

No-change rebuild to fix lpia shared library dependencies.

10. By James Westby

[ Martin Pool ]
Take patch from upstream to avoid deprecation warnings under python 2.6.
(LP: #337073)

9. By Matthias Klose

Explicitely use python2.5 to build the docs; the old doc tools are not
included in python2.6 anymore.

8. By Matthias Klose

* Merge from Debian lenny:
* Apply fix for CVE-2009-0544 (Buffer overflow in the ARC2 module), and
  a stand-alone version of the associated testcase (see
  http://www.openwall.com/lists/oss-security/2009/02/07/1).

7. By Matthias Klose

* Rebuild to include python2.6 build.
* Install the -dbg build using --install-layout=deb.

6. By Matthias Klose

* NMU.
* Fix build failure introduced in previous upload; add build dependency
  on texlive-fonts-recommended.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/python-crypto
This branch contains Public information 
Everyone can see this information.

Subscribers