lp:ubuntu/natty-proposed/pyside

Created by James Westby on 2011-06-06 and last modified on 2011-06-06
Get this branch:
bzr branch lp:ubuntu/natty-proposed/pyside
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

11. By Ricardo Salveti on 2011-05-11

* debian/patches/remove_opengl_detection_restriction.patch:
  - Remove the restriction of detecting QtOpenGL module just when gl.h is
    available at the system (LP: #707794)

10. By Didier Raboud on 2011-04-01

* New 1.0.1 upstream release
  - Bump the B-D chain versions:
    + generatorrunner to 0.6.8.
    + shiboken to 1.0.1.

* Move phonon-backend-gstreamer B-D earlier in the list to help the
  aptitude-based resolver (thanks to the pkg-kde team for the help!)
* Use dh_python2, hence get the debug files at the correct place.

9. By Didier Raboud on 2011-02-18

* New 1.0.0~rc1 upstream release
  - Bump the B-D chain versions:
    + apiextractor to 0.10.0-2~
    + generatorrunner to 0.6.6
    + shiboken to 1.0.0~rc1
* Update patches to ~rc1.
* debian/watch: update to handle Release Candidates too.
* Bump XS-Python-Version to >= 2.6.

8. By Didier Raboud on 2010-10-19

* New 0.4.2 upstream release.
  - Add some 0.4.1 and 0.4.2 symbols.
  - Bump apiextractor and shiboken B-D versions.
  - Update patches.
  - Update debian/dh_pycmakedeps to work with new upstream coding style.

* Patches:
  - u_c130273_fix_py25_QtScript_property.patch
    Remove, was from upstream.
  - u_20e226b_fix_missing_qcoreapplication_arguments_method.patch
    Remove, was from upstream.
  - u_268bf77_fixed_signal_signature_parser.patch
    Remove, was from upstream.
  + libPythonVersionPostfix.patch: Refresh
  + usePySpecificShiboken.patch: Refresh
  + lessBuildVerbosity.patch: Refresh

* Bump the B-D chain versions.
* Make sure the private.py is installed in QtCore module.
* Build against Qt 4.7.
  - Add libqtwebkit-dev
  - Drop QtMultimedia module.
  - Add the QtDeclarative package.

7. By Didier Raboud on 2010-09-27

* New 0.4.1 upstream release. (LP: #648612)
  - Add some 0.4.1 symbols.

* Patches:
  - u_c130273_fix_py25_QtScript_property.patch
    Remove, was from upstream.
  - u_20e226b_fix_missing_qcoreapplication_arguments_method.patch
    Remove, was from upstream.
  - u_268bf77_fixed_signal_signature_parser.patch
    Remove, was from upstream.
  + libPythonVersionPostfix.patch: Refresh
  + usePySpecificShiboken.patch: Refresh
  + lessBuildVerbosity.patch: Refresh

* Bump the B-D chain versions.
* Make sure the private.py is installed in QtCore module.
* Build against Qt 4.7.
  - Add libqtwebkit-dev
  - Drop QtMultimedia module.
  - Add the QtDeclarative package.

6. By Didier Raboud on 2010-06-18

* Run all tests but don't make them critical.
  - Update fixTests.patch to allow all tests.

* Reduce the build log size by forcing CMAKE_VERBOSE_MAKEFILE to OFF
  - Add lessBuildVerbosity.patch to add --silent option to
    generatorrunner.
  Closes: #586305

5. By Didier Raboud on 2010-06-16

* New 0.3.2 upstream release
  - Bump B-D on generatorrunner and shiboken
  - Update symbols

* Patches:
  - Remove all upstream patches that got merged upstream:
    u_fixConvenienceSymlinks_792456c.patch
    u_fixDebugPostfix_d9b1898.patch
    u_fixLinking_4326368.patch
    u_fixtestQtWebkitTest_17d9eed.patch
  × Refresh the others

* Blacklist some failing tests (reported upstream).
* Don't run the tests for the debug flavour (they fail).
* Override lintian warnings for the -dbg package.

4. By Didier Raboud on 2010-05-29

* Testsuite:
  - Blacklist qtnetwork_udpsocket that fails on the buildds

* Patches:
  - Import those hat got merged upstream
    × fix_Linking.patch
      -> u_fixLinking_4326368.patch
    × fixDebugPostfix.patch
      -> u_fixConvenienceSymlinks_792456c.patch
      -> u_fixDebugPostfix_d9b1898.patch
  - Fix the qtwebkit tests by importing
    + u_fixtestQtWebkitTest_17d9eed.patch from upstream

3. By Didier Raboud on 2010-05-11

* New 0.3.1 upstream release
  - Moves away from boost to fly with shiboken

* debian/rules
  - dh_install now lists missing files.
  - Multiple python versions tweak with custom cmake.
* debian/cmake/
  - Include patched FindPython*.cmake from #569321
* debian/control
  - Update Build-Depends list
* debian/copyright
  - Document new files
* Rename library to libpyside0.3
  - Add lintian override to be able to ship python specific files.
  - Ship proper (c++) symbols
* Update binary package list in debian/control and all .install files.
  - Add QtMultimedia
* Patches: remove all previous (new codebase), add new:
  + fixDebugPostix.patch: include debug postfix'ed files
  + libPythonVersionPostfix.patch: append -py* to the libraries
  + fixTests.patch: Correct LD_PRELOAD_PATH and blacklist some tests
  + fixLinking.patch: Get coherent linking troughout the plugins
* Re-enable -dbg build.

* Bump Standards to 3.8.4. No changes needed.

2. By Didier Raboud on 2009-08-26

* Initial release to Debian (Closes: #543636)
  - Use the Ubuntu packaging as starting point.
  - Convert to dh 7.
* debian/copyright: Update
* debian/control:
  - Change the library name to libpysidebase0.
  - Simplify Depends.
  - Set Debian Python Modules Team as Maintainer.
  - Add myself to Uploaders.
  - Add Vcs-* and Homepage fields.
  - Change binary packages names from pyside-$module to
    python-pyside.qt$module to fit with Debian Python Policy.
* debian/rules
  - Add tweaks to get multiple python versions built. It does not build on
    python 2.4, but is ready for 2.6.
  - Allow parallel build.
* debian/patches:
  - multiple_python_versions.patch: Add
  - use_cmake_no_config.patch : Add
  - debug_build_add_postfix.patch : Add
  - spelling_error_in_binary.patch: Add
* debian/watch: Add.
* Bump Standards to 3.8.3 - No changes needed.
* Use 3.0 (quilt) source format.

* -dbg build is disabled for now.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/pyside
This branch contains Public information 
Everyone can see this information.

Subscribers