lp:ubuntu/natty/packagekit

Created by James Westby on 2010-10-13 and last modified on 2011-04-04
Get this branch:
bzr branch lp:ubuntu/natty/packagekit
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

59. By Matthias Klumpp on 2011-03-24

Build-depend on xulrunner-dev or firefox-dev, which makes it
possible to compile PK without xulrunner as the
latter should go away. (LP: #740815)

58. By Steve Langasek on 2011-03-24

debian/rules: clean the dependency_libs out of .la files at build
time, per Policy 10.2

57. By Matthias Klumpp on 2011-03-16

Fix typo in Qt4 bindings (LP: #734939)

56. By Matthias Klumpp on 2011-01-25

* Select right browser on Debian/Ubuntu
* Reformatted control file
* Fix crash if Section() of a package is NULL
* Fix falure of some postinst scripts when running using APTcc (LP: #680328)

55. By Rohan Garg on 2011-01-10

* Merge from debian, remaining changes
  - Add ubuntu_01_null_selection_crash.diff

54. By Micah Gersten on 2010-12-20

* Add build-dep on libnspr4-dev so that the browser plugin can build
  - update debian/control

53. By Jonathan Riddell on 2010-12-20

Fix ubuntu_01_null_selection_crash.diff to include pk-backend-aptcc.cpp

52. By Jonathan Riddell on 2010-12-20

Add ubuntu_01_null_selection_crash.diff from
http://gitorious.org/packagekit/packagekit/commit/acd6cb4b68c21418a4
cd7a8c4c121d86d6b57aa5 Fix LP: #691474 bug which caused a crash when
the Section() of a package was NULL

51. By Julian Andres Klode on 2010-12-19

[ Matthias Klumpp ]
* Bumped debhelper version & added Gitignore
* Changed control file indentation

[ Julian Andres Klode ]
* Add support for GLib 2.24; thus upload to unstable
* Build with -Wl,--as-needed to avoid large dependencies
* Add myself to uploaders

50. By Matthias Klumpp on 2010-11-02

* New upstream release
   - This is the first release of PackageKit to support session
     configuration helper support in the GLib and Qt libraries.
   - This allows debconf to work when using PackageKit on Debian.
   - A formal transaction lifecyle is now in place, which allows future
     extensions to hook into the transaction at certain points.
* Disabled introspection support
  (requires a more recent version of gobject-introspection)
* APTcc proxy patch from upstream (makes APTcc use APT proxy settings)
* Upstream patch for some APTcc crashes

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/packagekit
This branch contains Public information 
Everyone can see this information.

Subscribers