lp:ubuntu/natty/mod-wsgi

Created by James Westby on 2010-10-13 and last modified on 2011-04-20
Get this branch:
bzr branch lp:ubuntu/natty/mod-wsgi
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

17. By James Page on 2011-04-20

* Full python >= 3.2 support (LP: #759943):
  - debian/patches/fix-python-3.2-lp-749720.patch: removed -
    superceded by python-3.2-compat.patch.
  - debian/patches/python-3.2-compat.patch: full patch to support
    python >= 3.2 from Graham Dumpleton.

16. By James Page on 2011-04-07

* Updates to support python >= 3.2 (LP: #749720):
  - Picked patch to support python >= 3.2 from upstream trunk.
  - Fixed libapache2-mod-wsgi-py3.postinst to correctly detect
    default python 3 version.
* Converted to source/format "3.0 (quilt)" and updated debhelper
  version (>= 7.0.15).

15. By Matthias Klose on 2010-12-03

Rebuild to add support for python 2.7.

14. By Piotr Ożarowski on 2010-09-26

Rebuild for Python 2.6.6 (Closes: #597915)

13. By Bernd Zeimetz on 2010-05-12

mod-wsgi needs to depend on libpython for Python > 2.5.
(Closes: #580425)

12. By Andrew Mitchell on 2010-04-27

Remove rule for placing the libpython2.6 dependency in shlibs.local
This makes libapache2-mod-wsgi depend on libpython2.6 (LP: #381961)

11. By Piotr Ożarowski on 2010-02-01

* Restart Apache instead of reloading config file in postinst (temporary
  workaround for bug #558608)
* Section changed to "httpd"
* Bump Standards-Version to 3.8.4 (no changes needed)

10. By Piotr Ożarowski on 2009-11-29

* New upstream release
* Remove postrm maintainer script, no longer needed as Lenny doesn't have
  mod-wsgi.{conf,load} anymore and this script was removing new files (which
  is handled by dpkg, closes: 558589)

9. By Piotr Ożarowski on 2009-10-11

* New upstream release
* configure-apache-version.dpatch removed, no longer needed
* Bump Standards-Version to 3.8.3 (no changes needed)

8. By Bernd Zeimetz on 2009-05-17

* New upstream bugfix release.
* Updating patches to suit the new version.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/mod-wsgi
This branch contains Public information 
Everyone can see this information.

Subscribers