lp:ubuntu/natty/liblocale-gettext-perl

Created by James Westby on 2010-10-13 and last modified on 2010-10-13
Get this branch:
bzr branch lp:ubuntu/natty/liblocale-gettext-perl
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

9. By Raphaël Hertzog on 2009-09-29

The -d option of dh_perl was lost by mistake while converting to tiny
rules files. Re-add it. Closes: #548860

8. By Colin Watson on 2008-06-14

Rebuild against Perl 5.10 on hppa.

7. By Raphaël Hertzog on 2008-05-07

* Put ${perl:Depends} back into Pre-Depends. The revert in 1.05-2 was
  wrong. The pre-dependency is needed to make sure that the right perl
  version is unpacked before liblocale-gettext-perl so that any
  script/module using Locale::Gettext (still) work once this module
  has been unpacked. This is particulary important for transitions like
  perl-5.8 -> perl-5.10 (see #479220 for example).
* New patch debian/patches/compatibility-with-POSIX-module.diff so that
  Locale::Gettext re-exports the LC_* constants coming from POSIX instead
  of those coming from its own XS implementation. Closes: #479803

6. By Michael Vogt on 2008-04-15

* debian/rules:
  - relax the dependencies to workaround ordering
    problem in apt on gutsy->hardy upgrade (LP: #217435)

5. By Raphaël Hertzog on 2008-02-03

[ Raphael Hertzog ]
* Move myself to Uploaders and put the team as Maintainer.
* Switch to debhelper's 6th compatibility mode. Ajust Build-Depends
  accordingly. Used debian/compat instead of DH_COMPAT.
* Remove versioned build-dependency on perl. oldstable already has a version
  new enough.
* Updated Standards-Version to 3.7.3 (no changes)
* Switched to quilt instead of old home-made dpatch based system.
  Added quilt to Build-Depends.
* Refreshed patch.
* Updated README.Debian.
* Remove empty /usr/share/perl5.
* Merge Pre-Depends into Depends since the reason of the use of Pre-Depends
  was wrong headed. Furthermor the bug it was working around is now fixed.

[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
  field (source stanza); Homepage field (source stanza). Removed: XS-
  Vcs-Svn fields.

4. By Kees Cook on 2007-08-14

No-change upload to enable stack protector.

3. By Raphaël Hertzog on 2005-06-22

* New upstream release
* Conforms to policy 3.6.2.
* Move ${perl:Depends} to Pre-Depends instead of Depends to avoid duplicate
  dependency. Fixes a lintian warning.

2. By Raphaël Hertzog on 2003-04-18

* Corrected typo in man page. Closes: #175421
* Updated section and priority (perl and standard respectively).
* Conform to policy 3.5.9.

1. By Raphaël Hertzog on 2002-08-14

Import upstream version 1.01

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/liblocale-gettext-perl
This branch contains Public information 
Everyone can see this information.

Subscribers