lp:ubuntu/natty-proposed/language-selector

Created by James Westby on 2011-04-26 and last modified on 2011-05-26
Get this branch:
bzr branch lp:ubuntu/natty-proposed/language-selector
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

122. By Gunnar Hjalmarsson on 2011-05-18

[ Gunnar Hjalmarsson ]
* LanguageSelector/FontConfig.py:
  - Make the fontconfig-voodoo --auto option work also when the first
    LANGUAGE item is just 'ja' or 'ko', i.e. without country code
    (LP: #778869).
* dbus_backend/ls-dbus-backend:
  - When applying the language settings system-wide, set the fonts
    configuration also when the first LANGUAGE item is just 'ja' or
    'ko' (LP: #778869).
* fontconfig-voodoo:
  - Do not require --force when removing the current config using the
    fontconfig-voodoo -r option.
  - Print an exception message if the --auto option fails to find a
    suitable configuration.

[ Martin Pitt ]
* debian/control: Switch Vcs-Bzr: to natty branch.

121. By Martin Pitt on 2011-05-08

LanguageSelector/LangCache.py: Ignore "-no" langpacks. These have been
split into -nb (Bokmal) and -nn (Nynorsk) ages ago, but unfortunately
language-support-writing-no is left in Natty, which causes a confusing
and non-working "Norwegian" entry in the "Add/remove languages" list. In
oneiric this was fixed properly by removing language-support-writing-no.
(LP: #773009)

120. By Martin Pitt on 2011-04-26

data/pkg_depends: Remove gnome-user-guide-*. The per-language packages
were removed in gnome-user-docs 2.91.90+git20110306ubuntu1. (LP: #771176)

119. By Martin Pitt on 2011-04-19

* dbus_backend/ls-dbus-backend: Actually look at the PolicyKit check result
  and only proceed if it succeeded. Thanks to Romain Perier for finding this
  and providing the patch! This fixes a local root privilege escalation, as
  this allows any authenticated user to write arbitrary shell commands into
  /etc/default/locale. (LP: #764397) [CVE-2011-0729]
* dbus_backend/ls-dbus-backend: Reject locale names with invalid characters
  in it, to further prevent injecting shell code into /etc/default/locale
  for authenticated users. Thanks to Felix Geyer for the initial patch!
  (LP: #764397)
* dbus_backend/com.ubuntu.LanguageSelector.conf: Allow access to standard
  D-BUS introspection and properties interfaces. There's no reason to deny
  it, and it causes warnings.
* debian/language-selector-common.postinst: Stop running D-BUS backend on
  upgrade.

118. By Gunnar Hjalmarsson on 2011-04-18

* help/C/language-selector.xml:
  - Description of how to open language-selector changed to also fit
    Unity.

117. By Gunnar Hjalmarsson on 2011-04-11

help/C/language-selector.xml: Tweaking of help document, LP: #742857

116. By Martin Pitt on 2011-04-08

LanguageSelector/gtk/GtkLanguageSelector.py: Fix crash when
double-clicking language row. (LP: #703097)

115. By Gunnar Hjalmarsson on 2011-04-06

[ Gunnar Hjalmarsson ]
* help/C/language-selector.xml:
  - Addition of DocBook document with help about Ubuntu i18n handling
    in general and language-selector in particular (LP: #742857).
* data/LanguageSelector.ui:
  - "Help" button added (LP: #742857).
  - Title of the main window changed to "Language Support", i.e.
    same as the name of the app/tool.
* LanguageSelector/gtk/GtkLanguageSelector.py:
  - Modified code for setlocale() exception handling.
* data/main-countries:
  - Changed the main country of English from GB to US. Not that the
    latter is more 'right' or something, but it may prevent failures
    in certain situations, since en_US locales are more widespread.

[ Martin Pitt ]
* data/pkg_depends: Add hunspell-sh.

114. By Martin Pitt on 2011-03-24

* data/pkg_depends: Install openoffice.org-hyphenation for the languages
  that it supports, when libreoffice-common is installed.
* data/pkg_depends: Add mythes-pl.
* data/pkg_depends: Add hyphen-pl.

113. By Martin Pitt on 2011-03-18

* data/pkg_depends: Update for libreoffice and changed thesaurus/hyphenation
  package names. Update test cases accordingly.
* data/pkg_depends: Add poppler-data for Arabic, Chinese, Japanese, and
  Korean. (LP: #623825)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/oneiric/language-selector
This branch contains Public information 
Everyone can see this information.

Subscribers