lp:ubuntu/natty-security/koffice

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/natty-security/koffice
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

76. By Marc Deslauriers

* SECURITY UPDATE: possible arbitrary code execution via malformed Word
  document (LP: #1032934)
  - debian/patches/wv2_buffer_overflow_fix.diff: don't overflow grupx in
    filters/kword/msword-odf/wv2/src/styles.cpp.
  - CVE number pending

75. By Scott Kitterman

* Only build-dep on libqt4-opengl-dev and libglew1.5-dev on [i386 amd64
  powerpc] to fix armel FTBFS due to the GL/GLES transition (LP: #707794)
  - Add debian/patches/kubuntu_06_krita_link_x.diff to fix indirect linking
    in krita (Thanks to Jonathan Riddell for the patch)

74. By Jonathan Riddell

Drop dependency on kformula which no longer exists

73. By Jonathan Riddell

Add kubuntu_05_libc_multiarch.diff, workaround libc now in multiarch
directory where cmake can not find it, proper solution should be in
cmake find_library(), to discuss with upstream

72. By Tarun K. Mall

* New upstream release (LP: #733227)
* Removed debian/kformula.install
* debian/control: commented lines regarding kformula, upstream
  recommends removing kformula atm.

71. By Jonathan Riddell

* Add build-dep on libglib2.0-dev and libgsf-1-dev
* Add kubuntu_04_findlibgsf.diff to find gsf includes

70. By Jonathan Riddell

Rebuild without dcmtk until it passes MIR

69. By Jonathan Riddell

* New upstream release
* Add kubuntu_03_libwpg_02.diff from Fedora for libwpg 0.2 support,
  add back libwpg-dev build-depend
* Depend on libwpd-dev not libwpd8-dev
* Remove kubuntu_02_kpresenterpart.diff now upstream

68. By Jonathan Riddell

* Remove build-depend on libwpg-dev, remove files from karbon.install
* Add kubuntu_02_kpresenterpart.diff to fix kpresenter okular plugin
* Build-dep on okular-dev, add package okular-odp-backend
* Add file debian/missing-build-depends to remind us why we don't have all
  upstream requested the build-depends
* Add build-dep on libdcmtk1-dev, add new files to kword.install

67. By Jonathan Riddell

New tar from upstream

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/koffice
This branch contains Public information 
Everyone can see this information.

Subscribers